summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Botting2018-03-25 21:55:27 +1100
committerAndy Botting2018-03-25 21:55:27 +1100
commite9d040135f2b587a57c0785113e835c1a330094a (patch)
tree4655cbb1b3db42137c5cc5d64cd01ce8e347c240
parent52cae99b064cf0eaf57c0c0963a25810347f46d4 (diff)
downloadaur-e9d040135f2b587a57c0785113e835c1a330094a.tar.gz
Update to v1.27.1-1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d02d0315936e..7708044b1029 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-shade
pkgdesc = Simple client library for interacting with OpenStack clouds
- pkgver = 1.26.0
+ pkgver = 1.27.1
pkgrel = 1
url = http://docs.openstack.org/infra/shade
arch = any
@@ -60,7 +60,7 @@ pkgbase = python-shade
makedepends = git
makedepends = python-setuptools
makedepends = python2-setuptools
- source = git+https://git.openstack.org/openstack-infra/shade#tag=1.26.0
+ source = git+https://git.openstack.org/openstack-infra/shade#tag=1.27.1
sha256sums = SKIP
pkgname = python-shade
diff --git a/PKGBUILD b/PKGBUILD
index d733b6b969c6..e4e8392fada3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_module='shade'
pkgname=('python-shade' 'python2-shade')
-pkgver='1.26.0'
+pkgver='1.27.1'
pkgrel='1'
pkgdesc='Simple client library for interacting with OpenStack clouds'
arch=('any')
@@ -39,13 +39,15 @@ source=("git+https://git.openstack.org/openstack-infra/${_module}#tag=${pkgver}"
sha256sums=('SKIP')
prepare() {
+ # Fix test function name
+ cd "${srcdir}/${_module}"
+ sed -i 's/assertItemsEqual/assertCountEqual/g' shade/tests/unit/*.py
+
cp -a "${srcdir}/${_module}"{,-py2}
}
build() {
cd "${srcdir}/${_module}"
- # Fix test function name for Python 3
- sed -i 's/assertItemsEqual/assertCountEqual/g' shade/tests/unit/*.py
# Fix TypeError: a bytes-like object is required, not 'str' for Python 3
sed -i 's/base64.b64encode(user_data)/base64.b64encode(user_data.encode())/g' shade/tests/unit/test_create_server.py
python setup.py build