summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvantu5z2021-01-14 16:04:39 +0300
committervantu5z2021-01-14 16:04:39 +0300
commit27f1a17617c33e2ef9a9d08629769c6d4b4a633d (patch)
treeedcb9e7e50b00584cc2933487a08163ef2e790b3
parent852eddb3f778fdde526e1e1a4a00408d10135dc9 (diff)
downloadaur-python-shell.tar.gz
mistake in source
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
2 files changed, 17 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec2a5f66177d..749e64b03e0f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = python-shell
- pkgdesc = Python Shell Wrapper Library. A better way to run shell commands in Python.
- pkgver = 1.0.4
- pkgrel = 2
- url = https://github.com/bart-tools/python-shell
+ pkgdesc = A better way to run shell commands in Python.
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/toastdriven/shell
arch = any
- license = MIT
+ license = BSD
makedepends = python-setuptools
depends = python
- depends = python-six
- source = https://github.com/bart-tools/python-shell/archive/stable/1.0.4.tar.gz
- sha256sums = a3e35889d44c0d3c8f52b07f0969560e985605e1f66161535e6ca548580d183c
+ source = https://github.com/toastdriven/shell/archive/v1.0.1.tar.gz
+ sha256sums = d114d74338877a8739ede11ef5466e950c5820a93d7dd20aa96408b2e353af0c
pkgname = python-shell
diff --git a/PKGBUILD b/PKGBUILD
index 38a05f10a6b8..8f6068758f58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
# Maintainer: vantu5z <vantu5z@mail.ru>
pkgname=python-shell
-pkgver=1.0.4
-pkgrel=2
-pkgdesc="Python Shell Wrapper Library. A better way to run shell commands in Python."
-url="https://github.com/bart-tools/python-shell"
-depends=('python' 'python-six')
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="A better way to run shell commands in Python."
+url="https://github.com/toastdriven/shell"
+depends=('python')
makedepends=('python-setuptools')
-license=('MIT')
+license=('BSD')
arch=('any')
-source=("https://github.com/bart-tools/python-shell/archive/stable/$pkgver.tar.gz")
-sha256sums=('a3e35889d44c0d3c8f52b07f0969560e985605e1f66161535e6ca548580d183c')
+source=("https://github.com/toastdriven/shell/archive/v$pkgver.tar.gz")
+sha256sums=('d114d74338877a8739ede11ef5466e950c5820a93d7dd20aa96408b2e353af0c')
build() {
- cd "${srcdir}/${pkgname}-stable-${pkgver}"
+ cd "${srcdir}/shell-${pkgver}"
python setup.py build
}
package() {
- cd "${srcdir}/${pkgname}-stable-${pkgver}"
+ cd "${srcdir}/shell-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}