summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordigital mystik2023-05-14 14:30:18 -0700
committerdigital mystik2023-05-14 14:30:18 -0700
commita90deb0db6700219da7db7b705d9056163d2c7db (patch)
tree7f1a73d7756643d8793166052a8759ff406ac143
downloadaur-python-simple-rlp.tar.gz
0.1.3
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c18d966d084a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-simple-rlp
+ pkgdesc = Encode and decode data structures
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = https://github.com/SamuelHaidu/simple-rlp
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = git
+ depends = python
+ source = python-simple-rlp-0.1.3::git+https://github.com/SamuelHaidu/simple-rlp.git#branch=master
+ b2sums = SKIP
+
+pkgname = python-simple-rlp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3905427a12fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: digital_mystik <dgtl_mystik at protonmail dot ch>
+
+_name=simple-rlp
+pkgname=python-simple-rlp
+pkgver=0.1.3
+pkgrel=1
+pkgdesc="Encode and decode data structures"
+arch=('any')
+url="https://github.com/SamuelHaidu/simple-rlp"
+license=("MIT")
+depends=('python')
+makedepends=('python-setuptools' 'git')
+source=("$pkgname-$pkgver::git+https://github.com/SamuelHaidu/simple-rlp.git#branch=master")
+
+b2sums=('SKIP')
+
+#source does not have tags currently
+
+#pkgver() {
+# cd "${pkgname}"
+# git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+#}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -D -m0644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}