summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-12-14 10:08:47 -0700
committerMark Wagie2023-12-14 10:08:47 -0700
commit064975013805606c8b19baaf75307d2e9f864536 (patch)
treee9b99871f4f4404c420bb97c1d524b1c2b5c36ac
parent9665d875fca6bf338db46c30cd94eb552800a5b5 (diff)
downloadaur-python-single-version.tar.gz
specify GIT_DIR and restore .gitignore
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD2
2 files changed, 8 insertions, 1 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index efdeef6d4971..1daa3ae705d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ sha256sums=('c7a07e5480a99086706f7c3b7ae9c06bf5df4bdbe3487a9c4de186f2ff154e0a')
build() {
cd "$_name-$pkgver"
- python -m build --wheel --no-isolation
+ GIT_DIR='.' python -m build --wheel --no-isolation
}
package() {