summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Elkouby2016-01-14 15:22:33 +0200
committerDan Elkouby2016-01-14 15:23:25 +0200
commit1a9ffff0cbdd3451a7c757dd406f24fe764dd113 (patch)
tree3b3afaa966f1f5957ed00a486489290b28168a19
downloadaur-1a9ffff0cbdd3451a7c757dd406f24fe764dd113.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD20
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e0492102be1c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Thu Jan 14 13:23:19 UTC 2016
+pkgbase = python-soco
+ pkgdesc = A simple Python class that allows you to programmatically control Sonos speakers
+ pkgver = 0.11.1
+ pkgrel = 1
+ url = https://github.com/SoCo/SoCo
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-requests
+ options = !emptydirs
+ source = https://github.com/SoCo/SoCo/archive/v0.11.1.tar.gz
+ md5sums = c0ff6775e70cea9cc26a01ad85a120ec
+
+pkgname = python-soco
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b65c71487e85
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/src/
+/pkg/
+*.tar.gz
+*.pkg.tar.xz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8817991661a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Dan Elkouby <streetwalrus@codewalr.us>
+pkgname=python-soco
+pkgver=0.11.1
+pkgrel=1
+pkgdesc="A simple Python class that allows you to programmatically control Sonos speakers"
+arch=('any')
+url="https://github.com/SoCo/SoCo"
+license=('MIT')
+depends=('python' 'python-requests')
+options=(!emptydirs)
+source=("https://github.com/SoCo/SoCo/archive/v$pkgver.tar.gz")
+md5sums=('c0ff6775e70cea9cc26a01ad85a120ec')
+
+package() {
+ cd "$srcdir/SoCo-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE.rst "$pkgdir/usr/share/licenses/$pkgname/LICENSE.rst"
+}
+
+# vim:set ts=2 sw=2 et: