summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTurtleRuss2024-04-30 05:48:07 +0800
committerTurtleRuss2024-04-30 05:48:07 +0800
commit768db3da4609f0acceed29de31e5f1173f9ec020 (patch)
tree8983fda5a64aa0e5cb1f9525908e5e43a32cb867
parentd5b6abe6976d0e080d003d5aa4843cb8ac27ed8b (diff)
downloadaur-768db3da4609f0acceed29de31e5f1173f9ec020.tar.gz
update to 0.30.3
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD15
2 files changed, 17 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4918dba20a79..a42f4b6b1bf0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,21 @@
pkgbase = python-soco
pkgdesc = A Python library that allows you to control Sonos speakers programmatically
- pkgver = 0.28.1
+ pkgver = 0.30.3
pkgrel = 1
url = https://github.com/SoCo/SoCo
arch = any
license = MIT
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
depends = python
depends = python-requests
depends = python-xmltodict
depends = python-ifaddr
- source = SoCo-0.28.1.tar.gz::https://github.com/SoCo/SoCo/archive/v0.28.1.tar.gz
- sha256sums = 012d60b19aeeef87cb2f016c3c08979ef509ac37795f8327b80fcf2078b21f39
+ depends = python-twisted
+ depends = python-aiohttp
+ depends = python-appdirs
+ depends = python-lxml
+ source = SoCo-0.30.3.tar.gz::https://github.com/SoCo/SoCo/archive/v0.30.3.tar.gz
+ sha256sums = SKIP
pkgname = python-soco
diff --git a/PKGBUILD b/PKGBUILD
index 8303ca6fb81a..4cde61db9ca6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,29 @@
-# Maintainer: m8D2 <omui (at) proton mail (dot) com>
+# Maintainer: TurtleRuss <tttturtleruss@gmail.com>
+# Contributor: m8D2 <omui (at) proton mail (dot) com>
# Contributor: novenary <streetwalkermc@gmail.com>
# Contributor: Daniel M. Capella <polyzen@archlinux.org>
pkgname=python-soco
-pkgver=0.28.1
+pkgver=0.30.3
pkgrel=1
pkgdesc="A Python library that allows you to control Sonos speakers programmatically"
arch=('any')
url="https://github.com/SoCo/SoCo"
license=('MIT')
-depends=('python' 'python-requests' 'python-xmltodict' 'python-ifaddr')
-makedepends=('python-setuptools')
+depends=('python' 'python-requests' 'python-xmltodict' 'python-ifaddr' 'python-twisted' 'python-aiohttp' 'python-appdirs' 'python-lxml')
+makedepends=('python-build' 'python-installer')
source=("SoCo-$pkgver.tar.gz::https://github.com/SoCo/SoCo/archive/v$pkgver.tar.gz")
-sha256sums=('012d60b19aeeef87cb2f016c3c08979ef509ac37795f8327b80fcf2078b21f39')
+sha256sums=('SKIP')
build() {
cd SoCo-$pkgver
- python setup.py build
+ python3 -m build
}
package() {
cd SoCo-$pkgver
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname LICENSE.rst
}