summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMelvin Vermeeren2018-05-04 19:44:00 +0200
committerMelvin Vermeeren2018-05-04 19:44:00 +0200
commita3924ccdee201b49ddb3050312138a798f3cb1b1 (patch)
treeba62983a857414623c8b193f02ae0c86234a0e3c
parentb9c52ae23790e76d00c5f3c51f2f65a60b28dfdf (diff)
downloadaur-python-sphinx-multibuild.tar.gz
fix python 3 module import, PR will be sent upstream
-rw-r--r--.SRCINFO6
-rw-r--r--0001-fix-compatibility-with-py3-when-installed-as-system-.patch23
-rw-r--r--PKGBUILD14
3 files changed, 36 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3408259a6941..b11daba31c97 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri May 4 15:27:52 UTC 2018
+# Fri May 4 17:43:12 UTC 2018
pkgbase = python-sphinx-multibuild
pkgdesc = Allow sphinx to build with multiple source directories and watch for changes.
pkgver = 1.1.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/rowanG077/sphinx-multibuild
arch = any
license = MIT
@@ -12,7 +12,9 @@ pkgbase = python-sphinx-multibuild
makedepends = python2
makedepends = python2-setuptools
source = https://files.pythonhosted.org/packages/source/s/sphinx-multibuild/sphinx-multibuild-1.1.1.tar.gz
+ source = 0001-fix-compatibility-with-py3-when-installed-as-system-.patch
sha256sums = 60e7f1ad87f585ecf323396cc43337ca6a39c275a412ce0d391d4adaa12b8a2d
+ sha256sums = 5a8a5daee7458f6311bd04b5799907319a7764238522d64daa72da4a6398abde
pkgname = python-sphinx-multibuild
depends = python
diff --git a/0001-fix-compatibility-with-py3-when-installed-as-system-.patch b/0001-fix-compatibility-with-py3-when-installed-as-system-.patch
new file mode 100644
index 000000000000..02c993488b6b
--- /dev/null
+++ b/0001-fix-compatibility-with-py3-when-installed-as-system-.patch
@@ -0,0 +1,23 @@
+From d21363d3e37a25c41dbb5c3441bdf6b201d52477 Mon Sep 17 00:00:00 2001
+From: Melvin Vermeeren <mail@mel.vin>
+Date: Fri, 4 May 2018 19:27:16 +0200
+Subject: [PATCH 1/2] fix compatibility with py3 when installed as system
+ module
+
+---
+ sphinx_multibuild/__init__.py | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/sphinx_multibuild/__init__.py b/sphinx_multibuild/__init__.py
+index fc0553f..6617ae0 100644
+--- a/sphinx_multibuild/__init__.py
++++ b/sphinx_multibuild/__init__.py
+@@ -1,3 +1,4 @@
+ #!/bin/env python
+ # -*- coding: utf-8 -*-
+-from sphinx_multibuild import SphinxMultiBuilder
++from __future__ import absolute_import
++from .sphinx_multibuild import SphinxMultiBuilder
+--
+2.17.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 1e08cded8803..874ceeca3927 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,22 @@
_name=sphinx-multibuild
pkgname=("python-${_name}" "python2-${_name}")
pkgver=1.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="Allow sphinx to build with multiple source directories and watch for changes."
arch=('any')
url="https://github.com/rowanG077/sphinx-multibuild"
license=('MIT')
makedepends=('python' 'python-setuptools' 'python2' 'python2-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('60e7f1ad87f585ecf323396cc43337ca6a39c275a412ce0d391d4adaa12b8a2d')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz"
+ '0001-fix-compatibility-with-py3-when-installed-as-system-.patch')
+sha256sums=('60e7f1ad87f585ecf323396cc43337ca6a39c275a412ce0d391d4adaa12b8a2d'
+ '5a8a5daee7458f6311bd04b5799907319a7764238522d64daa72da4a6398abde')
prepare() {
cd "$_name-$pkgver"
+ patch -Np1 -i ../0001-fix-compatibility-with-py3-when-installed-as-system-.patch
+
cp -a "${srcdir}/$_name-$pkgver" "${srcdir}/${_name}2-$pkgver"
}
@@ -22,12 +26,12 @@ package_python-sphinx-multibuild() {
depends=('python' 'python-setuptools' 'python-watchdog' 'python-sphinx')
cd "$_name-$pkgver"
- python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
}
package_python2-sphinx-multibuild() {
depends=('python2' 'python2-setuptools' 'python2-watchdog' 'python2-sphinx')
cd "${_name}2-$pkgver"
- python2 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+ python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
}