summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2023-01-11 10:56:09 +0800
committerUniversebenzene2023-01-11 10:56:09 +0800
commit5d1c2bbc91140b658bfdcc913edd100f0ecc595c (patch)
tree99bc4fea69812856ff8b6246b3e8c15ac36fda93
parent8903879619c03cce536c277c3051f90c1379c5a9 (diff)
downloadaur-python-sphinx_contributors.tar.gz
Update to version 0.2.7
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 58d281b5790f..17a7318bad1c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-sphinx_contributors
pkgdesc = Contributors extension for Sphinx
- pkgver = 0.2.6
+ pkgver = 0.2.7
pkgrel = 1
url = https://sphinx-contributors.readthedocs.io
arch = any
@@ -10,13 +10,13 @@ pkgbase = python-sphinx_contributors
makedepends = python-build
makedepends = python-installer
makedepends = python-sphinx-furo
- source = https://files.pythonhosted.org/packages/source/s/sphinx_contributors/sphinx_contributors-0.2.6.tar.gz
- md5sums = baaf61ea142bb2b7e27097c7821b454f
+ source = https://files.pythonhosted.org/packages/source/s/sphinx_contributors/sphinx_contributors-0.2.7.tar.gz
+ md5sums = 7ff8fe3657645ce61639ade0d82b12fc
pkgname = python-sphinx_contributors
depends = python>=3.7
depends = python-sphinx>=3
- optdepends = python-sphinx_contributors-doc: Documentation for ndcube
+ optdepends = python-sphinx_contributors-doc: Documentation for sphinx-contributors
pkgname = python-sphinx_contributors-doc
pkgdesc = Documentation for sphinx contributors
diff --git a/PKGBUILD b/PKGBUILD
index 14afcc54b871..8c1109d8f6ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=python-sphinx_contributors
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python-${_pyname}-doc")
-pkgver=0.2.6
+pkgver=0.2.7
pkgrel=1
pkgdesc="Contributors extension for Sphinx"
arch=('any')
@@ -15,7 +15,7 @@ makedepends=('python-flit-core'
'python-sphinx-furo')
checkdepends=('python-pytest') #python-sphinx
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('baaf61ea142bb2b7e27097c7821b454f')
+md5sums=('7ff8fe3657645ce61639ade0d82b12fc')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -24,19 +24,18 @@ build() {
msg "Building Docs"
mkdir -p dist/lib
bsdtar -xpf dist/${_pyname/-/_}-${pkgver}-py3-none-any.whl -C dist/lib
- cd ${srcdir}/${_pyname}-${pkgver}/docs
- PYTHONPATH="../dist/lib" make html
+ PYTHONPATH="../dist/lib" make -C docs html
}
check() {
cd ${srcdir}/${_pyname}-${pkgver}
- PYTHONPATH="dist/lib" pytest || warning "Tests failed"
+ PYTHONPATH="dist/lib" pytest || warning "Tests failed" # -vv --color=yes
}
package_python-sphinx_contributors() {
depends=('python>=3.7' 'python-sphinx>=3')
- optdepends=('python-sphinx_contributors-doc: Documentation for ndcube')
+ optdepends=('python-sphinx_contributors-doc: Documentation for sphinx-contributors')
cd ${srcdir}/${_pyname}-${pkgver}
install -D -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE.md