summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShohei Maruyama2023-08-06 00:26:34 +0900
committerShohei Maruyama2023-08-06 00:40:58 +0900
commit1250d12be0d81cda6715b126858514bc50d65d60 (patch)
tree957c99bca18d7f16f8df6b3d882e1e5706153c1b
downloadaur-python-sphinxcontrib-mermaid.tar.gz
Initial commit
Signed-off-by: Shohei Maruyama <cheat.sc.linux@outlook.com>
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD43
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c74f97272d3b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-sphinxcontrib-mermaid
+ pkgdesc = Mermaid diagrams in yours sphinx powered docs
+ pkgver = 0.9.2
+ pkgrel = 1
+ url = https://pypi.org/project/sphinxcontrib-mermaid/
+ arch = any
+ license = BSD
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/s/sphinxcontrib-mermaid/sphinxcontrib-mermaid-0.9.2.tar.gz
+ sha256sums = 353f6893066e7a6ef469330ed1e66ca319435b7efab631b2c14470ea84ac056b
+
+pkgname = python-sphinxcontrib-mermaid
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7eca0f0e8604
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/src/
+/pkg/
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ffc67a338036
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Shohei Maruyama <cheat.sc.linux@outlook.com>
+
+pkgname='python-sphinxcontrib-mermaid'
+_name=${pkgname#python-}
+pkgver=0.9.2
+pkgrel=1
+pkgdesc='Mermaid diagrams in yours sphinx powered docs'
+arch=('any')
+url='https://pypi.org/project/sphinxcontrib-mermaid/'
+license=('BSD')
+depends=(
+ 'python'
+ 'python-sphinx'
+)
+makedepends=(
+ 'python-build'
+ 'python-installer'
+ 'python-wheel'
+)
+checkdepends=(
+ 'python-pytest'
+)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('252ef13dd23164b28f16d8b0205cf184b9d8e2b714a302274d9f59eb708e77af')
+
+build() {
+ cd "$_name-$pkgver"
+
+ python -m build --wheel --no-isolation
+}
+
+check(){
+ cd "$_name-$pkgver"
+
+ pytest --fixtures
+}
+
+package() {
+ cd "$_name-$pkgver"
+
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -vDm 644 LICENSE.rst -t "${pkgdir}/usr/share/licenses/${pkgname}/"
+}