summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2020-01-29 22:22:22 +0000
committerGrey Christoforo2020-01-29 22:22:22 +0000
commit470dbeef698bd36d9c7d3b29ae6ca0d7979003a9 (patch)
tree7bd8b9e647165960928129841105536340b30fb1
parentfbd678e76ea8d013b15f85ab8ebc5366b61a122c (diff)
downloadaur-python-spritex.tar.gz
fix the badness
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9845a7698922..51bb1843bd62 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,13 +11,8 @@ pkgbase = python-spritex
depends = python-kivy
depends = python-pillow
depends = xclip
- source = https://files.pythonhosted.org/packages/source/s/spritex/spritex-0.1.3.tar.gz
- md5sums = 6ba03731f5e48b1864bd696c886921cc
+ source = https://github.com/codetorex/spritex/archive/0.1.3.tar.gz
+ md5sums = 1f276da550ffc52447731cd4976ea941
pkgname = python-spritex
- depends = python
- depends = python-numpy
- depends = python-kivy
- depends = python-pillow
- depends = xclip
diff --git a/PKGBUILD b/PKGBUILD
index 7c4e284b4aab..de8280317b1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,8 @@
# Maintainer: Grey Christoforo <first name at last name dot net>
-pkgbase=('python-spritex')
-pkgname=('python-spritex')
-_module='spritex'
-pkgver='0.1.3'
+pkgname=python-spritex
+_module=spritex
+pkgver=0.1.3
pkgrel=1
pkgdesc="A simple tool for extracting sprites from full frames. Useful for AI projects. "
url="https://github.com/codetorex/spritex"
@@ -11,8 +10,9 @@ depends=('python' 'python-numpy' 'python-kivy' 'python-pillow' 'xclip')
makedepends=('python-setuptools')
license=('MIT')
arch=('any')
-source=("https://files.pythonhosted.org/packages/source/s/spritex/spritex-${pkgver}.tar.gz")
-md5sums=('6ba03731f5e48b1864bd696c886921cc')
+source=("https://github.com/codetorex/spritex/archive/${pkgver}.tar.gz")
+#source=("https://files.pythonhosted.org/packages/source/s/spritex/spritex-${pkgver}.tar.gz")
+md5sums=('1f276da550ffc52447731cd4976ea941')
build() {
cd "${srcdir}/${_module}-${pkgver}"
@@ -20,7 +20,6 @@ build() {
}
package() {
- depends+=()
cd "${srcdir}/${_module}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}