summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSara Jakša2017-05-07 21:13:08 +0200
committerSara Jakša2017-05-07 21:13:08 +0200
commit9b300c4f5b1f29005745e17b04460a38318b64eb (patch)
treef421986abe5cf2623a12bd9419ad2b3b62a7b9db
downloadaur-python-stackapi-git.tar.gz
Initial AUR Archive commit of 'python-stackapi-git'
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..138cfef9f1c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-stackapi-git
+ pkgdesc = A python wrapper for the StackOverflow and StackExchange API
+ pkgver = 0.1.8
+ pkgrel = 1
+ url = https://github.com/AWegnerGitHub/stackapi
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python-docutils
+ depends = python-requests
+ provides = python-stackapi
+ conflicts = python-stackapi
+ source = python-stackapi-git::git://github.com/AWegnerGitHub/stackapi.git
+ md5sums = SKIP
+
+pkgname = python-stackapi-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4c0bbfcebdf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Sara Jakša <sarajaksa@gmail.com>
+# Based on willemw <willemw12@gmail.com> build for python-code-chat
+
+_pkgname=python-stackapi
+pkgname=$_pkgname-git
+pkgver=0.1.8
+pkgrel=1
+pkgdesc="A python wrapper for the StackOverflow and StackExchange API"
+arch=('any')
+url="https://github.com/AWegnerGitHub/stackapi"
+license=('MIT')
+depends=('python-docutils' 'python-requests')
+makedepends=('git' 'python-setuptools')
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=($pkgname::git://github.com/AWegnerGitHub/stackapi.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd $pkgname
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+