summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authora8212025-03-03 13:33:35 +0100
committera8212025-03-03 13:33:35 +0100
commit5f026422e6fdd4cf0ea8d1caa1693ecf131a5254 (patch)
tree04fa6e5ca1ae7fd221e2098ee8cb7cb413cd7d7c
parentde5e4c7c2aece175c15943ab690d8067badc7625 (diff)
downloadaur-python-stdlib-list.tar.gz
Version 0.11.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
2 files changed, 9 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0fe957e3f61b..e75bfe164ce3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-stdlib-list
pkgdesc = A list of Python Standard Libraries
- pkgver = 0.10.0
- pkgrel = 2
+ pkgver = 0.11.1
+ pkgrel = 1
url = https://github.com/pypi/stdlib-list
arch = any
license = MIT
@@ -11,7 +11,7 @@ pkgbase = python-stdlib-list
makedepends = python-installer
makedepends = python-flit-core
depends = python
- source = python-stdlib-list::git+https://github.com/pypi/stdlib-list#commit=21e67eef5898d27004442f68e84f2b8a847e319a
- b2sums = SKIP
+ source = python-stdlib-list::git+https://github.com/pypi/stdlib-list#commit=v0.11.1
+ b2sums = b5b32df65b31bcd9c55c41cc5a46707d837e9ffc3180b28ae7509eb3f1b47d757f494d2166616daa94e5c4aa0c4b3423008b24b84699ac39e7f30b19c8c12c27
pkgname = python-stdlib-list
diff --git a/PKGBUILD b/PKGBUILD
index 60c0dd5f6732..fc4d94388e51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: George Rawlinson <grawlinson@archlinux.org>
+# Contributor: George Rawlinson <grawlinson@archlinux.org>
# Contributor: Philipp A. <flying-sheep@web.de>
pkgname=python-stdlib-list
-pkgver=0.10.0
-pkgrel=2
+pkgver=0.11.1
+pkgrel=1
pkgdesc='A list of Python Standard Libraries'
arch=('any')
url='https://github.com/pypi/stdlib-list'
@@ -16,25 +16,16 @@ makedepends=(
'python-flit-core'
)
checkdepends=('python-pytest')
-_commit='21e67eef5898d27004442f68e84f2b8a847e319a'
-source=("$pkgname::git+$url#commit=$_commit")
-b2sums=('SKIP')
-
-pkgver() {
- cd "$pkgname"
-
- git describe --tags | sed 's/^v//'
-}
+source=("$pkgname::git+$url#commit=v$pkgver")
+b2sums=('b5b32df65b31bcd9c55c41cc5a46707d837e9ffc3180b28ae7509eb3f1b47d757f494d2166616daa94e5c4aa0c4b3423008b24b84699ac39e7f30b19c8c12c27')
build() {
cd "$pkgname"
-
python -m build --wheel --no-isolation
}
check() {
cd "$pkgname"
-
pytest -v
}