summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-12-27 09:04:15 -0800
committerxiota2023-12-27 09:04:15 -0800
commit572ae6962b627cd00d7cc271e02a8ef5d084d04f (patch)
tree5057ae8e3ff5aab113d46aab929a468882224642
parent3c87dd3e266bacf19af23c628b813d40b894c1b0 (diff)
downloadaur-python-supersolids.tar.gz
PEP517
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD67
3 files changed, 61 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10d80662f5c0..9ec17ba978d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,25 @@
pkgbase = python-supersolids
pkgdesc = Simulate and animate supersolids by solving the Schrödinger equation
pkgver = 0.1.33
- pkgrel = 1
- url = https://github.com/Scheiermann/supersolids
+ pkgrel = 2
+ url = https://pypi.org/project/supersolids
arch = any
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
- depends = ffmpeg
+ makedepends = python-wheel
+ depends = python
+ source = supersolids-0.1.33.tar.gz::https://files.pythonhosted.org/packages/source/s/supersolids/supersolids-0.1.33.tar.gz
+ sha256sums = 01d7068678a577fcf6b8b4a5785a00333128ad22d9e4596c3dd3c1eba7103e7e
+
+pkgname = python-supersolids
+ depends = python
depends = python-dill
- depends = python-ffmpeg
depends = python-matplotlib
depends = python-numpy
depends = python-psutil
- depends = python-pyqt5
+ depends = python-ffmpeg-python
depends = python-scipy
- depends = python-sphinx-autoapi
- depends = python-sphinx_rtd_theme
- optdepends =
- source = supersolids-0.1.33.tar.gz::https://files.pythonhosted.org/packages/source/s/supersolids/supersolids-0.1.33.tar.gz
- sha256sums = 01d7068678a577fcf6b8b4a5785a00333128ad22d9e4596c3dd3c1eba7103e7e
-
-pkgname = python-supersolids
+ depends = vtk
+ depends = python-mayavi
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 305451587466..5c37058adcd3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,54 @@
-# Maintainer: Daniel Scheiermann <daniel.scheiermann@stud.uni-hannover.de>
-_name=supersolids
-pkgname=python-${_name}
+# Maintainer:
+# Contributor: Daniel Scheiermann <daniel.scheiermann@stud.uni-hannover.de>
+
+## useful links:
+# https://pypi.org/project/supersolids
+# https://github.com/Scheiermann/supersolids
+
+_module="supersolids"
+_pkgname="python-$_module"
+pkgname="$_pkgname"
pkgver=0.1.33
-pkgrel=1
+pkgrel=2
pkgdesc="Simulate and animate supersolids by solving the Schrödinger equation"
-url="https://github.com/Scheiermann/${_name}"
-arch=(any)
+url="https://pypi.org/project/supersolids"
license=("MIT")
-depends=("ffmpeg" "python-dill" "python-ffmpeg" "python-matplotlib" "python-numpy" "python-psutil"
- "python-pyqt5" "python-scipy" "python-sphinx-autoapi" "python-sphinx_rtd_theme"
- )
-makedepends=("python-setuptools")
-optdepends=("")
-source=(${_name}-$pkgver.tar.gz::"https://files.pythonhosted.org/packages/source/${_name::1}/$_name/${_name}-$pkgver.tar.gz")
+arch=(any)
+
+depends=('python')
+makedepends=(
+ 'python-build'
+ 'python-installer'
+ 'python-setuptools'
+ 'python-wheel'
+)
+
+_pkgsrc="$_module-$pkgver"
+_pkgext="tar.gz"
+source=("$_pkgsrc.$_pkgext"::"https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_pkgsrc.$_pkgext")
sha256sums=('01d7068678a577fcf6b8b4a5785a00333128ad22d9e4596c3dd3c1eba7103e7e')
build() {
- cd "$srcdir/${_name}-$pkgver"
- python setup.py build
-}
-
-check_disabled() {
- cd "$srcdir/${_name}-$pkgver"
- python setup.py test
+ cd "$_pkgsrc"
+ python -m build --wheel --no-isolation
}
package() {
- cd "$srcdir/${_name}-$pkgver"
- # install mayavi, vtk is needed
- python -m pip install -U vtk
- python -m pip install -U mayavi
- python setup.py install --skip-build --root="$pkgdir" --optimize=1
+ depends+=(
+ 'python-dill'
+ 'python-matplotlib'
+ 'python-numpy'
+ 'python-psutil'
+ 'python-ffmpeg-python'
+ 'python-scipy'
+ 'vtk'
+
+ # AUR
+ 'python-mayavi'
+ # python-envisage
+ )
+ cd "$_pkgsrc"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 LICENSE.rst "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}