summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2022-01-23 20:37:07 +1100
committerMatthew Gamble2022-01-23 20:37:07 +1100
commitf657955c5d323186fccb8ed53f0ee7f9b7a90c8d (patch)
treecfdacc583c80d66a975ea91ecae2403fbc63621e
parent61a459f9d01bde375157da17ef802b6f00c5623f (diff)
downloadaur-python-tatsu.tar.gz
Update to latest release - v5.7.3
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b18f8084860f..460186daf153 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = python-tatsu
pkgdesc = TatSu takes a grammar in a variation of EBNF as input, and outputs a memoizing PEG/Packrat parser in Python.
- pkgver = 5.6.1
- pkgrel = 3
+ pkgver = 5.7.3
+ pkgrel = 1
url = https://github.com/neogeny/TatSu
arch = any
license = BSD
makedepends = python-setuptools
depends = python
- depends = python-pytest-runner
optdepends = python-regex
- source = https://pypi.io/packages/source/T/TatSu/TatSu-5.6.1.zip
- sha256sums = 6a4f07aa7bfe9dfbee8015824feaf13f0b1a89577e2ee5a4a62c18630c309d4e
+ source = https://pypi.io/packages/source/T/TatSu/TatSu-5.7.3.zip
+ sha256sums = cf1f3b16fc4f8c8f4d0135749407dc01c10051c34ce1f6c7e859867d89b5ac69
pkgname = python-tatsu
diff --git a/PKGBUILD b/PKGBUILD
index 35cf4753ea83..c654c281217c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,17 @@
# Contributor: carstene1ns <arch carsten-teibes de>
pkgname=python-tatsu
-pkgver=5.6.1
-pkgrel=3
+pkgver=5.7.3
+pkgrel=1
pkgdesc="TatSu takes a grammar in a variation of EBNF as input, and outputs a memoizing PEG/Packrat parser in Python."
arch=("any")
url="https://github.com/neogeny/TatSu"
license=("BSD")
-# TODO: Remove python-pytest-runner once this issue is resolved:
-# https://github.com/neogeny/TatSu/issues/216
-depends=("python" "python-pytest-runner")
+depends=("python")
optdepends=("python-regex")
-makedepends=('python-setuptools')
+makedepends=("python-setuptools")
source=("https://pypi.io/packages/source/T/TatSu/TatSu-${pkgver}.zip")
-sha256sums=("6a4f07aa7bfe9dfbee8015824feaf13f0b1a89577e2ee5a4a62c18630c309d4e")
+sha256sums=("cf1f3b16fc4f8c8f4d0135749407dc01c10051c34ce1f6c7e859867d89b5ac69")
build() {
cd "TatSu-${pkgver}"