summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlarchunix2024-02-03 21:53:32 +0100
committerlarchunix2024-02-03 21:53:32 +0100
commit3bfd6170bfb99eb07b977cc1744c1ea3015112d6 (patch)
tree82d4a42d5d85432b56453cc54e2903dbbbc71e2b
parent2e8b21b9b372622bf6d2c51076ebe137d4af922c (diff)
downloadaur-python-templated-dictionary.tar.gz
Update to upstream release 1.4-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
2 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db3307d2c429..1e130f604dcd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-templated-dictionary
pkgdesc = Dictionary where every item is evaluated as a Jinja2 expression
- pkgver = 1.2
- pkgrel = 1
+ pkgver = 1.4
+ pkgrel = 1.1
url = https://github.com/xsuchy/templated-dictionary
arch = any
- license = GPL2
+ license = GPL-2.0-or-later
makedepends = python-setuptools
depends = python
depends = python-jinja
- source = https://files.pythonhosted.org/packages/source/t/templated-dictionary/templated-dictionary-1.2.tar.gz
- sha256sums = 6972d3bca252b39cb4d87c35657016fa964e94b218c136d4642f08c60a0886fb
+ source = https://github.com/xsuchy/templated-dictionary/archive/python-templated-dictionary-1.4-1.tar.gz
+ sha256sums = 2fdc220dd5f931ac9149a8d01d1a6d9334d093da514581cdd0175cc72e6542d9
pkgname = python-templated-dictionary
diff --git a/PKGBUILD b/PKGBUILD
index e415d4fc7600..9499c3503e50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,21 @@
pkgname=python-templated-dictionary
_name=${pkgname#python-}
-pkgver=1.2
-pkgrel=1
+pkgver=1.4
+_rpmrel=1
+_pkgtag=$pkgname-$pkgver-$_rpmrel
+pkgrel=$_rpmrel.1
pkgdesc="Dictionary where every item is evaluated as a Jinja2 expression"
arch=('any')
url="https://github.com/xsuchy/templated-dictionary"
-license=('GPL2')
+license=('GPL-2.0-or-later')
depends=('python' 'python-jinja')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('6972d3bca252b39cb4d87c35657016fa964e94b218c136d4642f08c60a0886fb')
+source=("$url/archive/$_pkgtag.tar.gz")
+sha256sums=('2fdc220dd5f931ac9149a8d01d1a6d9334d093da514581cdd0175cc72e6542d9')
+
+prepare() {
+ mv "$_name-$_pkgtag" "$_name-$pkgver"
+}
build() {
cd "$_name-$pkgver"