summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid McInnis2016-04-22 18:32:32 -0700
committerDavid McInnis2016-04-22 18:32:32 -0700
commit008747c70983c201299daa5125c3864a6b2244d5 (patch)
tree053258e863af555b2788abec4d6d75b69ef8ac59
parentc552bfa6c3b7e746dc70ea13f6c1bb9c7e4195b8 (diff)
downloadaur-008747c70983c201299daa5125c3864a6b2244d5.tar.gz
version bump
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Fix-problem-with-python-3.5.patch44
-rw-r--r--PKGBUILD16
3 files changed, 12 insertions, 58 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7374c1e05573..f03105b6f5a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Mar 31 01:23:27 UTC 2016
+# Sat Apr 23 01:32:20 UTC 2016
pkgbase = python-theano
pkgdesc = Definition and optimized evaluation of mathematical expressions on Numpy arrays.
- pkgver = 0.8.1
+ pkgver = 0.8.2
pkgrel = 1
url = http://www.deeplearning.net/software/theano/
arch = any
@@ -24,10 +24,8 @@ pkgbase = python-theano
optdepends = python2-pydot-ng
optdepends = python-pydot
optdepends = python2-pygpu
- source = http://pypi.python.org/packages/source/T/Theano/Theano-0.8.1.tar.gz
- source = 0001-Fix-problem-with-python-3.5.patch
- sha256sums = 2f1d9ad7ecf136e7978a6720fa9286f7b02221c5599b935e9f7fa14cd29cb19d
- sha256sums = b522bb513278635487a8e50f5d6b1aca003900cc92fd2450ac843daeb6c69216
+ source = http://pypi.python.org/packages/30/3d/2354fac96ca9594b755ec22d91133522a7db0caa0877165a522337d0ed73/Theano-0.8.2.tar.gz
+ sha256sums = 7463c8f7ed1a787bf881f36d38a38607150186697e7ce7e78bfb94b7c6af8930
pkgname = python-theano
depends = python
diff --git a/0001-Fix-problem-with-python-3.5.patch b/0001-Fix-problem-with-python-3.5.patch
deleted file mode 100644
index 2a475b6c35f8..000000000000
--- a/0001-Fix-problem-with-python-3.5.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From 78154521097a852dd82c614580e730ab1cd132ad Mon Sep 17 00:00:00 2001
-From: Pascal Lamblin <lamblinp@iro.umontreal.ca>
-Date: Tue, 22 Mar 2016 11:45:25 -0400
-Subject: [PATCH] Fix problem with python 3.5.
-
-It would raise a SystemError wrapping the IndexError already raised.
----
- theano/tensor/subtensor.py | 9 +++++++--
- 1 file changed, 7 insertions(+), 2 deletions(-)
-
-diff --git a/theano/tensor/subtensor.py b/theano/tensor/subtensor.py
-index 4d3deca..112db06 100644
---- a/theano/tensor/subtensor.py
-+++ b/theano/tensor/subtensor.py
-@@ -1956,6 +1956,7 @@ class AdvancedIncSubtensor1(Op):
- copy_of_x = self.copy_of_x(x)
-
- return """
-+ PyObject* rval = NULL;
- if (%(inplace)s)
- {
- if (%(x)s != %(out)s)
-@@ -1971,12 +1972,16 @@ class AdvancedIncSubtensor1(Op):
- %(out)s = %(copy_of_x)s;
- }
- PyObject *arglist = Py_BuildValue("OOOi",%(out)s, %(idx)s, %(y)s, %(inc_or_set)d);
-- inplace_increment(NULL, arglist);
-+ rval = inplace_increment(NULL, arglist);
- Py_XDECREF(arglist);
-+ if (rval == NULL) {
-+ %(fail)s;
-+ }
-+ Py_XDECREF(rval);
- """ % locals()
-
- def c_code_cache_version(self):
-- return (1,)
-+ return (2,)
-
- def perform(self, node, inp, out_):
- # TODO opt to make this inplace
---
-2.7.4
-
diff --git a/PKGBUILD b/PKGBUILD
index 9fd66b391c9a..9443c6094e42 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase="python-theano"
pkgname=("python-theano" "python2-theano")
_pkgname="Theano"
-pkgver="0.8.1"
+pkgver="0.8.2"
pkgrel="1"
pkgdesc='Definition and optimized evaluation of mathematical expressions on Numpy arrays.'
arch=('any')
@@ -22,16 +22,16 @@ optdepends=('python-sympy: Recommended'
'python2-pydot-ng'
'python-pydot'
'python2-pygpu')
-source=("http://pypi.python.org/packages/source/T/Theano/Theano-${pkgver}.tar.gz"
- "0001-Fix-problem-with-python-3.5.patch")
-sha256sums=('2f1d9ad7ecf136e7978a6720fa9286f7b02221c5599b935e9f7fa14cd29cb19d'
- 'b522bb513278635487a8e50f5d6b1aca003900cc92fd2450ac843daeb6c69216')
+source=("http://pypi.python.org/packages/30/3d/2354fac96ca9594b755ec22d91133522a7db0caa0877165a522337d0ed73/Theano-${pkgver}.tar.gz")
+sha256sums=('7463c8f7ed1a787bf881f36d38a38607150186697e7ce7e78bfb94b7c6af8930')
+#https://pypi.python.org/packages/30/3d/2354fac96ca9594b755ec22d91133522a7db0caa0877165a522337d0ed73/Theano-0.8.2.tar.gz
+
prepare() {
cd "${_pkgname}-${pkgver}"
chmod +x "${_pkgname}.egg-info"
chmod 644 ${_pkgname}.egg-info/*
- patch -p1 < ../0001-Fix-problem-with-python-3.5.patch
+ chmod -R a+r ./
cd "$srcdir/"
cp -a "${_pkgname}-${pkgver}" "${_pkgname}-${pkgver}-py2"
cd "${_pkgname}-${pkgver}"
@@ -82,12 +82,12 @@ package_python2-theano() {
mv "${pkgdir}/usr/bin/theano-cache" "${pkgdir}/usr/bin/theano2-cache"
mv "${pkgdir}/usr/bin/theano-nose" "${pkgdir}/usr/bin/theano2-nose"
mv "${pkgdir}/usr/bin/theano-test" "${pkgdir}/usr/bin/theano2-test"
- install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/python2-theano"
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/python2-theano/LICENSE.txt"
}
package_python-theano() {
depends=('python' 'python-numpy')
cd "$srcdir/${_pkgname}-${pkgver}"
python setup.py install --root="$pkgdir"/ --optimize=1
- install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/python-theano"
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/python-theano/LICENSE.txt"
}