summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSZanko2021-02-01 11:14:45 +0100
committerSZanko2021-02-01 11:14:45 +0100
commit27886a78346a027f394759f5df1ae0a2581645a2 (patch)
tree20d62ec2ded86b0c8a1fde9e6941d0071c7204dd
parent2e1aeff5d40e315195c27fe60f1ade707b11b345 (diff)
downloadaur-27886a78346a027f394759f5df1ae0a2581645a2.tar.gz
Updated Version to 1.05 and outcommented the python2 build process
Signed-off-by: SZanko <szanko@protonmail.com>
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD52
3 files changed, 36 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ed893524f7f..662b26642c7c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = python-theano
pkgdesc = Definition and optimized evaluation of mathematical expressions on Numpy arrays.
- pkgver = 1.0.4
- pkgrel = 3
+ pkgver = 1.0.5
+ pkgrel = 1
url = http://www.deeplearning.net/software/theano/
arch = any
license = BSD
makedepends = python-distribute
- makedepends = python2-distribute
- source = https://files.pythonhosted.org/packages/source/T/Theano/Theano-1.0.4.tar.gz
- sha256sums = 35c9bbef56b61ffa299265a42a4e8f8cb5a07b2997dabaef0f8830b397086913
+ source = https://files.pythonhosted.org/packages/source/T/Theano/Theano-1.0.5.tar.gz
+ sha256sums = 6e9439dd53ba995fcae27bf20626074bfc2fff446899dc5c53cb28c1f9202e89
pkgname = python-theano
depends = python-numpy
@@ -21,13 +20,3 @@ pkgname = python-theano
optdepends = python-scikit-sparse
optdepends = python-mpi4py: minimal support for opencl
-pkgname = python2-theano
- depends = python2-numpy
- optdepends = python2-sympy: Recommended
- optdepends = python2-scipy: Recommended
- optdepends = python2-pycuda
- optdepends = python2-pydot-ng: Preferred over python-pydot
- optdepends = python2-pydot
- optdepends = python2-pygpu-git
- optdepends = python2-mpi4py: minimal support for opencl
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e4e8efd624e6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/pkg
+/src
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index b74845c829be..28139591d53e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,24 @@
# Maintainer: David McInnis <dave@dave3.xyz>
pkgbase="python-theano"
-pkgname=("python-theano" "python2-theano")
+pkgname=(
+ "python-theano"
+ #"python2-theano"
+)
_pkgname="Theano"
-pkgver="1.0.4"
-pkgrel="3"
+pkgver="1.0.5"
+pkgrel="1"
pkgdesc='Definition and optimized evaluation of mathematical expressions on Numpy arrays.'
arch=('any')
url='http://www.deeplearning.net/software/theano/'
license=('BSD')
-makedepends=('python-distribute' 'python2-distribute')
+makedepends=(
+ 'python-distribute'
+ #'python2-distribute'
+ )
#checkdepends=('python-nose' 'python-parameterized' 'python2-nose' 'python2-parameterized')
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
-sha256sums=('35c9bbef56b61ffa299265a42a4e8f8cb5a07b2997dabaef0f8830b397086913')
+sha256sums=('6e9439dd53ba995fcae27bf20626074bfc2fff446899dc5c53cb28c1f9202e89')
prepare() {
cd "${_pkgname}-${pkgver}"
@@ -29,9 +35,9 @@ prepare() {
}
build() {
- msg "Building Python 2"
- cd "$srcdir/${_pkgname}-${pkgver}-py2"
- python2 setup.py build
+ # msg "Building Python 2"
+ # cd "$srcdir/${_pkgname}-${pkgver}-py2"
+ # python2 setup.py build
msg "Building Python 3"
cd "$srcdir/${_pkgname}-${pkgver}"
@@ -52,21 +58,21 @@ build() {
# nosetests3 -vv -d
#}
-package_python2-theano() {
- depends=('python2-numpy')
- optdepends=('python2-sympy: Recommended'
- 'python2-scipy: Recommended'
- 'python2-pycuda'
- 'python2-pydot-ng: Preferred over python-pydot'
- 'python2-pydot'
- 'python2-pygpu-git'
- 'python2-mpi4py: minimal support for opencl')
- cd "$srcdir/${_pkgname}-${pkgver}-py2"
- python2 setup.py install --root="$pkgdir"/ --optimize=1 --skip-build
- mv "${pkgdir}/usr/bin/theano-cache" "${pkgdir}/usr/bin/theano2-cache"
- mv "${pkgdir}/usr/bin/theano-nose" "${pkgdir}/usr/bin/theano2-nose"
- install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/python2-theano/LICENSE.txt"
-}
+#package_python2-theano() {
+# depends=('python2-numpy')
+# optdepends=('python2-sympy: Recommended'
+# 'python2-scipy: Recommended'
+# 'python2-pycuda'
+# 'python2-pydot-ng: Preferred over python-pydot'
+# 'python2-pydot'
+# 'python2-pygpu-git'
+# 'python2-mpi4py: minimal support for opencl')
+# cd "$srcdir/${_pkgname}-${pkgver}-py2"
+# python2 setup.py install --root="$pkgdir"/ --optimize=1 --skip-build
+# mv "${pkgdir}/usr/bin/theano-cache" "${pkgdir}/usr/bin/theano2-cache"
+# mv "${pkgdir}/usr/bin/theano-nose" "${pkgdir}/usr/bin/theano2-nose"
+# install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/python2-theano/LICENSE.txt"
+#}
package_python-theano() {
depends=('python-numpy')