summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid McInnis2018-06-07 05:12:34 -0700
committerDavid McInnis2018-06-07 05:12:34 -0700
commit326c5d84f1b64efd98b7667fd2e2c7a716e2ec22 (patch)
treeaccbbb741d8965ffacf9a7c8ec9c1e84e981efeb
parent3d353b5ab955098e6ffb85fcfa92a475b87a80c8 (diff)
downloadaur-326c5d84f1b64efd98b7667fd2e2c7a716e2ec22.tar.gz
version bump
-rw-r--r--PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e4e9d7aab33e..3e4a8827b833 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase="python-theano"
pkgname=("python-theano" "python2-theano")
_pkgname="Theano"
-pkgver="1.0.1"
+pkgver="1.0.2"
pkgrel="1"
pkgdesc='Definition and optimized evaluation of mathematical expressions on Numpy arrays.'
arch=('any')
@@ -28,8 +28,8 @@ optdepends=('python-sympy: Recommended'
'python2-pygpu-git'
'python2-pydot'
'python2-mpi4py')
-source=("https://pypi.python.org/packages/62/da/ab486aae8e538d8ae91fa0e6ab26d3a454d7c5c7a66541f40300e58a3314/Theano-${pkgver}.tar.gz")
-sha256sums=('88d8aba1fe2b6b75eacf455d01bc7e31e838c5a0fb8c13dde2d9472495ff4662')
+source=("https://pypi.python.org/packages/99/dd/e43e3da5dd52f1468def552ed3e752bfd6958369478cc906ff07b21af92e/Theano-${pkgver}.tar.gz")
+sha256sums=('6768e003d328a17011e6fca9126fbb8a6ffd3bb13cb21c450f3e724cca29abde')
prepare() {
cd "${_pkgname}-${pkgver}"
@@ -59,15 +59,15 @@ build() {
# All Python and Python2 tests pass except theano.tensor.tests.test_mpi.test_mpi_roundtrip
#
# -------------------------------------------------
-#check() {
-# msg "Checking Python 2"
-# cd "$srcdir/${_pkgname}-${pkgver}-py2"/build/lib/theano/
-# nosetests2 -vv -d
-#
-# msg "Checking Python 3"
-# cd "$srcdir/${_pkgname}-${pkgver}"/build/lib/theano/
-# nosetests3 -vv -d
-#}
+check() {
+ msg "Checking Python 2"
+ cd "$srcdir/${_pkgname}-${pkgver}-py2"/build/lib/theano/
+ nosetests2 -vv -d
+
+ msg "Checking Python 3"
+ cd "$srcdir/${_pkgname}-${pkgver}"/build/lib/theano/
+ nosetests3 -vv -d
+}
package_python2-theano() {
depends=('python2' 'python2-numpy')