summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid McInnis2017-12-08 06:25:40 -0800
committerDavid McInnis2017-12-08 06:25:40 -0800
commit4c59b6742b3306eb965f61515b818cfedf0176ad (patch)
treeb412784f826a288ac3eaefce379e85319bbfcf4b
parentf9ef6b6951317b67dc1049223c2a8ae93e6a2601 (diff)
downloadaur-4c59b6742b3306eb965f61515b818cfedf0176ad.tar.gz
bumped to bersion 1.0.0
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 22 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06ef2d7c50e3..8de4ba164b5d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
-# Generated by mksrcinfo v8
-# Thu Mar 23 21:27:29 UTC 2017
pkgbase = python-theano
pkgdesc = Definition and optimized evaluation of mathematical expressions on Numpy arrays.
- pkgver = 0.9.0
+ pkgver = 1.0.0
pkgrel = 1
url = http://www.deeplearning.net/software/theano/
arch = any
license = BSD
checkdepends = python-nose
- checkdepends = python-nose-parameterized
+ checkdepends = python-parameterized
checkdepends = python2-nose
- checkdepends = python2-nose-parameterized
+ checkdepends = python2-parameterized
makedepends = python-distribute
makedepends = python2-distribute
depends = python
@@ -19,20 +17,21 @@ pkgbase = python-theano
depends = python2-numpy
optdepends = python-sympy: Recommended
optdepends = python-scipy: Recommended
- optdepends = python-pycuda:
+ optdepends = python-pycuda
optdepends = python-pydot-ng: Preferred over python-pydot
optdepends = python-pydot
- optdepends = python-pygpu
+ optdepends = python-pygpu-git
optdepends = python-scikit-sparse
optdepends = python-mpi4py: minimal support for opencl
optdepends = python2-sympy
optdepends = python2-scipy
optdepends = python2-pycuda
optdepends = python2-pydot-ng
+ optdepends = python2-pygpu-git
optdepends = python2-pydot
optdepends = python2-mpi4py
- source = http://pypi.python.org/packages/28/03/6af9ff242da966f89de6ab81164db0d1a36fd89379b7370f07043de62f10/Theano-0.9.0.tar.gz
- sha256sums = 745d66716531f9063127274b40503fbc21f931f78b7b03e79e5523d50078bc17
+ source = https://pypi.python.org/packages/8d/74/99cc011153b3a566e98729cfee1b8b00af157e2b6047d23ee0871fd5e706/Theano-1.0.0.tar.gz
+ sha256sums = 7bc82e4fcaac023cac23c390b30d5df81bc09d33568812df75b0bd2b86d2fa8f
pkgname = python-theano
depends = python
diff --git a/PKGBUILD b/PKGBUILD
index 955d1f9d7cf2..7fa9e04fd38c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: David McInnis <davidm@eagles.ewu.edu>
+# Maintainer: David McInnis <dave@dave3.xyz>
pkgbase="python-theano"
pkgname=("python-theano" "python2-theano")
_pkgname="Theano"
-pkgver="0.9.0"
+pkgver="1.0.0"
pkgrel="1"
pkgdesc='Definition and optimized evaluation of mathematical expressions on Numpy arrays.'
arch=('any')
@@ -12,24 +12,25 @@ license=('BSD')
depends=('python' 'python-numpy'
'python2' 'python2-numpy')
makedepends=('python-distribute' 'python2-distribute')
-checkdepends=('python-nose' 'python-nose-parameterized' 'python2-nose' 'python2-nose-parameterized')
+checkdepends=('python-nose' 'python-parameterized' 'python2-nose' 'python2-parameterized')
optdepends=('python-sympy: Recommended'
'python-scipy: Recommended'
- 'python-pycuda:'
+ 'python-pycuda'
'python-pydot-ng: Preferred over python-pydot'
'python-pydot'
- 'python-pygpu'
+ 'python-pygpu-git'
'python-scikit-sparse'
'python-mpi4py: minimal support for opencl'
'python2-sympy'
'python2-scipy'
'python2-pycuda'
'python2-pydot-ng'
+ 'python2-pygpu-git'
'python2-pydot'
'python2-mpi4py')
-source=("http://pypi.python.org/packages/28/03/6af9ff242da966f89de6ab81164db0d1a36fd89379b7370f07043de62f10/Theano-${pkgver}.tar.gz")
-sha256sums=('745d66716531f9063127274b40503fbc21f931f78b7b03e79e5523d50078bc17')
-
+source=("https://pypi.python.org/packages/8d/74/99cc011153b3a566e98729cfee1b8b00af157e2b6047d23ee0871fd5e706/Theano-${pkgver}.tar.gz")
+sha256sums=('7bc82e4fcaac023cac23c390b30d5df81bc09d33568812df75b0bd2b86d2fa8f')
+
prepare() {
cd "${_pkgname}-${pkgver}"
chmod +x "${_pkgname}.egg-info"
@@ -54,22 +55,18 @@ build() {
python setup.py build
}
-# All CPU tests for Python2 pass on my machine, but the
-# theano.tensor.tests.test_mpi.test_mpi_roundtrip test
-# for Python3 Hangs indefinitely
-# many CUDA tests fail on my machine
-# My Nvidia 9600GT is old & requires cuda65 to work
+# Tests take many hours and need over 8G of memory
+# All Python and Python2 tests pass except theano.tensor.tests.test_mpi.test_mpi_roundtrip
+#
#-------------------------------------------------
#check() {
# msg "Checking Python 2"
# cd "$srcdir/${_pkgname}-${pkgver}-py2"/build/lib/theano/
-# ../../../bin/theano-cache clear
-# THEANO_FLAGS=cuda.enabled=False nosetests2 -v -d
+# nosetests2 -vv -d
#
# msg "Checking Python 3"
# cd "$srcdir/${_pkgname}-${pkgver}"/build/lib/theano/
-# ../../../bin/theano-cache clear
-# THEANO_FLAGS=cuda.enabled=False nosetests3 -v -d
+# nosetests3 -vv -d
#}
package_python2-theano() {