summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-03-23 19:13:32 -0500
committerLuis Martinez2022-03-23 19:13:32 -0500
commitf1855af84486e782cfd461909087185b8bba8ec5 (patch)
treeccf4fbe55f2af28b0be5373f700b81897cb30012
parent6dd5ca64367e3c6e00630d16481b038947680224 (diff)
downloadaur-python-tidylib.tar.gz
update to 0.3.2
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD41
2 files changed, 42 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae7549a5b4cc..2ed991a59574 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
-# Generated by mksrcinfo v8
-# Sun Apr 3 09:37:47 UTC 2016
pkgbase = python-tidylib
pkgdesc = Python bindings for Tidy HTML parser/cleaner.
- pkgver = 0.2.4
- pkgrel = 2
- url = http://countergram.com/open-source/pytidylib
- arch = i686
- arch = x86_64
+ pkgver = 0.3.2
+ pkgrel = 1
+ url = https://github.com/countergram/pytidylib
+ arch = any
license = MIT
+ makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = tidyhtml
depends = python
- source = https://github.com/countergram/pytidylib/archive/0.2.4.tar.gz
- sha256sums = 5bdc5a6889742ae0a8be21166fe92c895b23dd4114db39bb23bffe66db3c9079
+ provides = python-pytidylib
+ source = python-tidylib-0.3.2.tar.gz::https://files.pythonhosted.org/packages/source/p/pytidylib/pytidylib-0.3.2.tar.gz
+ sha256sums = 22b1c8d75970d8064ff999c2369e98af1d0685417eda4c829a5c9f56764b0af3
pkgname = python-tidylib
-
diff --git a/PKGBUILD b/PKGBUILD
index 4303a5547f9d..14013f2c751b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,39 @@
-# Maintainer: Alexander Minges <alexander.minges@gmail.com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Alexander Minges <alexander.minges@gmail.com>
# Contributor: Antonio Lucas <antonioluccas@gmail.com>
+
pkgname=python-tidylib
-_realname=pytidylib
-pkgver=0.2.4
-pkgrel=2
+pkgver=0.3.2
+pkgrel=1
pkgdesc="Python bindings for Tidy HTML parser/cleaner."
-arch=('i686' 'x86_64')
-url="http://countergram.com/open-source/${_realname}"
+arch=('any')
+url="https://github.com/countergram/pytidylib"
license=('MIT')
depends=('tidyhtml' 'python')
-source=("https://github.com/countergram/${_realname}/archive/$pkgver.tar.gz")
-sha256sums=('5bdc5a6889742ae0a8be21166fe92c895b23dd4114db39bb23bffe66db3c9079')
+makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
+provides=('python-pytidylib')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/p/pytidylib/pytidylib-$pkgver.tar.gz")
+sha256sums=('22b1c8d75970d8064ff999c2369e98af1d0685417eda4c829a5c9f56764b0af3')
+
+build() {
+ cd "pytidylib-$pkgver"
+ ## dependency check fails due to slicing errors
+ python -m build --wheel --skip-dependency-check --no-isolation
+}
+
+check() {
+ cd "pytidylib-$pkgver"
+ python -m unittest discover
+}
package() {
- cd $startdir/src/$_realname-$pkgver
- python setup.py install --root=$pkgdir --optimize=1 || return 1
+ export PYTHONHASHSEED=0
+ cd "pytidylib-$pkgver"
+ python -m installer --destdir="$pkgdir/" dist/*.whl
+
+ local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
+ install -d "$pkgdir/usr/share/licenses/$pkgname/"
+ ln -s \
+ "$_site/pytidylib-$pkgver.dist-info/LICENSE" \
+ "$pkgdir/usr/share/licenses/$pkgname/"
}