summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2023-09-24 12:43:03 -0500
committerCarlos Aznarán2023-09-24 12:43:03 -0500
commit8084ec6a1fae044063b9755092eae97bd5e6f225 (patch)
tree7bc88a05439819621e505a45f56c07324c038f9f
parent4fbcde18e58e83d825b5cd3f7f0f5b2f4a7158ba (diff)
downloadaur-python-triangle.tar.gz
Bump version to 20230923
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 7 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 743f7d6ef0ea..7bbe1d7125d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-triangle
pkgdesc = Python bindings to the triangle library
- pkgver = 20220202
- pkgrel = 3
+ pkgver = 20230923
+ pkgrel = 1
url = https://github.com/drufat/triangle
arch = any
license = LGPL3
@@ -13,13 +13,9 @@ pkgbase = python-triangle
makedepends = git
depends = python-numpy
optdepends = python-matplotlib: for Matplotlib rendering
- source = git+https://github.com/drufat/triangle.git?#tag=v20220202
+ source = git+https://github.com/drufat/triangle.git?#tag=v20230923
source = git+https://github.com/drufat/triangle-c.git
- source = drop-python36.patch::https://github.com/drufat/triangle/pull/66.patch
- source = python311-compatibilty.patch::https://github.com/drufat/triangle/pull/67.patch
sha512sums = SKIP
sha512sums = SKIP
- sha512sums = a3d405d64cb6f2bb6896acfaef72859294acd95d55c09a2bfef2f49fbe2fc7b98fa955e8b4ff6b2dd49c38e23ef8a88e69b01b09b39f9aa6fb709d264236701d
- sha512sums = 52d55f0ea2e97c852ebb26dd0e395018bbc8e58b6230567a92d2aeb590eb08da851eaa0e88df3e2d89454e921fec4f8fe51367dc59b6d4a28fbbbcbf70503742
pkgname = python-triangle
diff --git a/PKGBUILD b/PKGBUILD
index a281a90ce6ef..bf72e0964ea2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
_base=triangle
pkgname=python-${_base}
-pkgver=20220202
-pkgrel=3
+pkgver=20230923
+pkgrel=1
pkgdesc="Python bindings to the triangle library"
url="https://github.com/drufat/${_base}"
arch=(any)
@@ -12,19 +12,12 @@ depends=(python-numpy) # triangle
makedepends=(python-build python-installer python-setuptools cython python-wheel git)
optdepends=('python-matplotlib: for Matplotlib rendering')
source=(git+${url}.git?#tag=v${pkgver}
- git+${url}-c.git
- drop-python36.patch::${url}/pull/66.patch
- python311-compatibilty.patch::${url}/pull/67.patch)
+ git+${url}-c.git)
sha512sums=('SKIP'
- 'SKIP'
- 'a3d405d64cb6f2bb6896acfaef72859294acd95d55c09a2bfef2f49fbe2fc7b98fa955e8b4ff6b2dd49c38e23ef8a88e69b01b09b39f9aa6fb709d264236701d'
- '52d55f0ea2e97c852ebb26dd0e395018bbc8e58b6230567a92d2aeb590eb08da851eaa0e88df3e2d89454e921fec4f8fe51367dc59b6d4a28fbbbcbf70503742')
+ 'SKIP')
prepare() {
cd ${_base}
- # https://github.com/drufat/triangle/issues/69
- patch -p1 -i ../drop-python36.patch
- patch -p1 -i ../python311-compatibilty.patch
git submodule init
git config submodule.libs/c.url "${srcdir}/${_base}-c"
git -c protocol.file.allow=always submodule update