summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAkechiShiro2023-07-28 01:31:36 +0200
committerAkechiShiro2023-07-28 01:31:36 +0200
commit2eef4276cb132862f8b7b37f1bc1934a2239c081 (patch)
treecc828e62586c57a5cdcf05344aba3348b9493043
parent849b21042fdf5de8798226c6086ecc4e300a637c (diff)
downloadaur-python-ubi-reader-git.tar.gz
Add conflict python-ubi-reader and add enhancements from comments
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d84f05ca0621..aff31975869b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-ubi-reader-git
pkgdesc = Scripts for reading information about and extracting data from UBI and UBIFS images.
- pkgver = v0.8.6.r2.gdc9075c
+ pkgver = 0.8.9.r2.gcc7225e
pkgrel = 1
url = https://github.com/onekey-sec/ubi_reader
arch = any
@@ -8,14 +8,14 @@ pkgbase = python-ubi-reader-git
checkdepends = python-pytest
checkdepends = python-pytest-cov
makedepends = git
- makedepends = python-pip
makedepends = python-build
makedepends = python-installer
makedepends = python-wheel
makedepends = python-setuptools
makedepends = python-poetry
depends = python
- provides = python-ubi-reader
+ provides = python-ubi-reader=0.8.9
+ conflicts = python-ubi-reader
source = git+https://github.com/onekey-sec/ubi_reader
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 10119769c558..3549d335f180 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,23 @@
_pyname=ubi_reader
pkgname=python-${_pyname//_/-}-git
-pkgver=v0.8.6.r2.gdc9075c
+pkgver=0.8.9.r2.gcc7225e
pkgrel=1
pkgdesc='Scripts for reading information about and extracting data from UBI and UBIFS images.'
arch=('any')
url="https://github.com/onekey-sec/$_pyname"
license=(GPL)
depends=(python)
-conflicts=()
-provides=(python-ubi-reader)
-makedepends=(git python-pip python-build python-installer python-wheel python-setuptools python-poetry)
+conflicts=(python-ubi-reader)
+provides=("python-ubi-reader=${pkgver%.r*}")
+makedepends=(git python-build python-installer python-wheel python-setuptools python-poetry)
checkdepends=(python-pytest python-pytest-cov)
source=("git+https://github.com/onekey-sec/$_pyname")
sha256sums=(SKIP)
pkgver() {
cd "$_pyname"
- git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed -E "s/v([^v]*)/\1/" | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {