summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2021-04-14 22:24:01 -0400
committerGuillaume Horel2021-04-14 22:24:01 -0400
commit716730b0661f16c3ba4e1911aa8d4c0d7ca3bc04 (patch)
treefc87f3a24e8677c50f40d610bd8683693c2bdc83
downloadaur-python-untokenize.tar.gz
initial import
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4d50ba58ff39
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = python-untokenize
+ pkgdesc = Transforms tokens into source code
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/myint/untokenize
+ arch = any
+ license = MIT
+ source = https://files.pythonhosted.org/packages/source/u/untokenize/untokenize-0.1.1.tar.gz
+ sha256sums = 3865dbbbb8efb4bb5eaa72f1be7f3e0be00ea8b7f125c69cbd1f5fda926f37a2
+
+pkgname = python-untokenize
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f952d3855f5c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+pkgname='python-untokenize'
+_pkgname='untokenize'
+pkgver=0.1.1
+pkgrel=1
+pkgdesc='Transforms tokens into source code'
+url='https://github.com/myint/untokenize'
+checkdepends=()
+depends=()
+makedepends=()
+optdepends=()
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('3865dbbbb8efb4bb5eaa72f1be7f3e0be00ea8b7f125c69cbd1f5fda926f37a2')
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}
+
+check() {
+ cd "$_pkgname-$pkgver"
+ python test_untokenize.py
+}
+