summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Perry (Pezz)2018-05-10 13:10:22 +1000
committerSimon Perry (Pezz)2018-05-10 13:10:22 +1000
commit1d878ec7dd2c1b481b08be649902808451e7cbe7 (patch)
treedf25bcb639623d639916388be6ed789d7e4bea52
downloadaur-python-validate_email-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db4b8c2f533c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-validate_email-git
+ pkgdesc = Python library that checks if an email is valid, properly formatted and really exists
+ pkgver = r39.eaf2668
+ pkgrel = 1
+ url = https://github.com/syrusakbary/validate_email
+ arch = any
+ license = LGPL
+ makedepends = python-setuptools
+ source = git+https://github.com/syrusakbary/validate_email.git
+ sha256sums = SKIP
+
+pkgname = python-validate_email-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0d05cb4fdff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Simon Perry <aur [at] sanxion [dot] net>
+
+pkgname=python-validate_email-git
+_distname=validate_email
+pkgver=r39.eaf2668
+pkgrel=1
+pkgdesc="Python library that checks if an email is valid, properly formatted and really exists"
+arch=('any')
+license=('LGPL')
+url="https://github.com/syrusakbary/validate_email"
+makedepends=('python-setuptools')
+source=("git+https://github.com/syrusakbary/validate_email.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_distname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}"/"${_distname}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}"/"${_distname}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+}
+