summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorotaj2022-12-05 10:56:18 +0100
committerotaj2022-12-05 10:56:18 +0100
commit5ec315d501c459fa35ba04d5ab9b82c349d4ac49 (patch)
tree64bbb8f4af30c3ece60e51e5b41372695ee9566d
parent8f3e0f187f45ebfc9419c1f17421b417e0fbea80 (diff)
downloadaur-python-visdom-git.tar.gz
verbump
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2d0a2139d4dc..957e4e983555 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = python-visdom-git
pkgdesc = Visualization tool for Pytorch by Facebook
- pkgver = r314.bc71e86
+ pkgver = 0.2.3.r24.g56f72f7
pkgrel = 1
url = https://github.com/facebookresearch/visdom
+ install = visdom.install
arch = any
license = Apache
makedepends = git
@@ -16,6 +17,9 @@ pkgbase = python-visdom-git
depends = python-six
depends = python-jsonpatch
depends = python-pillow
+ depends = python-networkx
+ provides = python-visdom
+ conflicts = python-visdom
options = !emptydirs
source = git+https://github.com/facebookresearch/visdom.git
source = visdom.conf
@@ -25,7 +29,3 @@ pkgbase = python-visdom-git
sha256sums = d71fbfa6bb3feecfb1997a459da196f8a2f0f50b33428043921803d97db5562c
pkgname = python-visdom-git
- install = visdom.install
- provides = python-visdom
- conflicts = python-visdom
-
diff --git a/PKGBUILD b/PKGBUILD
index fcdad3d5bff5..91e3d1d5c6c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,13 @@
_pkgbase="visdom"
pkgname=python-visdom-git
-pkgver=r314.bc71e86
+pkgver=0.2.3.r24.g56f72f7
pkgrel=1
arch=(any)
url='https://github.com/facebookresearch/visdom'
pkgdesc='Visualization tool for Pytorch by Facebook'
license=(Apache)
-depends=('python-websocket-client' 'python-numpy' 'python-scipy' 'python-requests' 'python-tornado' 'python-pyzmq' 'python-six' 'python-jsonpatch' 'python-pillow')
+depends=('python-websocket-client' 'python-numpy' 'python-scipy' 'python-requests' 'python-tornado' 'python-pyzmq' 'python-six' 'python-jsonpatch' 'python-pillow' 'python-networkx')
makedepends=(
'git'
'python-setuptools'
@@ -27,7 +27,7 @@ sha256sums=('SKIP'
pkgver() {
cd "${_pkgbase}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | sed 's/^v//g'
}
package() {