summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2023-11-02 10:42:29 +0100
committerFabioLolix2023-11-02 10:42:29 +0100
commit9b59653812b5b4a19f2d2993f393046f58acf83e (patch)
treee671ef448865ee43959e16f63b27fbcf9f2b3754
parent527692faf098637756a95591171882afa10b22f2 (diff)
downloadaur-python-vulkan.tar.gz
update license, makedepnds
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c4b464c570c..031e0f06bf0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = python-vulkan
pkgdesc = The ultimate Python binding for Vulkan API
pkgver = 1.1.99.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/realitix/vulkan
arch = any
- license = MIT
- makedepends = python-pycparser
+ license = Apache
+ makedepends = python-build
+ makedepends = python-wheel
+ makedepends = python-installer
+ makedepends = python-setuptools
depends = python
depends = python-cffi
depends = vulkan-icd-loader
- options = !emptydirs
- source = https://github.com/realitix/vulkan/archive/1.1.99.1.tar.gz
+ source = python-vulkan-1.1.99.1.tar.gz::https://github.com/realitix/vulkan/archive/1.1.99.1.tar.gz
sha384sums = 43675c9ae7092a31b02478768da8bb89ec53bca74dafa692f9fac687e096e40dc8cef879f104e84d0b8a1e18b5853ff7
pkgname = python-vulkan
diff --git a/PKGBUILD b/PKGBUILD
index 8fa0772e8e73..585539671d58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
# Maintainer: Dario Ostuni <dario.ostuni@gmail.com>
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org>
pkgname=python-vulkan
pkgver=1.1.99.1
-pkgrel=2
+pkgrel=3
pkgdesc="The ultimate Python binding for Vulkan API"
arch=('any')
url="https://github.com/realitix/vulkan"
-license=('MIT')
+license=('Apache')
depends=('python' 'python-cffi' 'vulkan-icd-loader')
-makedepends=('python-pycparser')
-options=(!emptydirs)
-source=("https://github.com/realitix/vulkan/archive/${pkgver}.tar.gz")
+makedepends=('python-build' 'python-wheel' 'python-installer' 'python-setuptools')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/realitix/vulkan/archive/${pkgver}.tar.gz")
sha384sums=('43675c9ae7092a31b02478768da8bb89ec53bca74dafa692f9fac687e096e40dc8cef879f104e84d0b8a1e18b5853ff7')
build() {
- cd "$srcdir/vulkan-${pkgver}"
+ cd "vulkan-${pkgver}"
python -m build --wheel --no-isolation
}
package() {
- cd "$srcdir/vulkan-${pkgver}"
+ cd "vulkan-${pkgver}"
python -m installer --destdir="$pkgdir" dist/*.whl
}