summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2023-02-15 22:53:26 -0600
committerLuis Martinez2023-02-15 22:53:26 -0600
commit1503c5a17199b90999f1f0e647f980269e052592 (patch)
tree4f250a14a68afd5421fa279e10ac83e7d5e99643
parenta0b595c3687df29940d21b469b0434893c3d08be (diff)
downloadaur-python-webssh.tar.gz
update to 1.6.1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD57
2 files changed, 42 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e5d16ec2a38..1817dec5d3a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,25 @@
pkgbase = python-webssh
- pkgdesc = A SSH Web Front End
- pkgver = 1.5.3
+ pkgdesc = Web-based SSH client
+ pkgver = 1.6.1
pkgrel = 1
url = https://github.com/huashengdun/webssh
arch = any
- license = Apache
- makedepends = python
+ license = MIT
+ checkdepends = python-pytest
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
- depends = python-tornado
+ makedepends = python-wheel
depends = python-paramiko
+ depends = python-tornado
backup = etc/conf.d/webssh
- source = https://files.pythonhosted.org/packages/source/w/webssh/webssh-1.5.3.tar.gz
+ source = python-webssh-1.6.1.tar.gz::https://files.pythonhosted.org/packages/source/w/webssh/webssh-1.6.1.tar.gz
source = webssh.conf.d
source = webssh.service
source = sysusers.conf
- sha256sums = 02ee8f13c8d89bc2e4129d01d72996fff664ae4715d016aec2e7d09ab1cb114e
+ sha256sums = 83745141459b8c745a65155e92611372b1d8795208a5eb5e08287ba36f2304b6
sha256sums = d14c4c025468b8a4801b8f93dccad10da638934ec394bf34f9523bbcfe358286
sha256sums = cd7f5fc4b81fc1757fca6c00b5fadf1e24954d6c21682e6a3876b0de9e7be291
sha256sums = 5f4eca9aeb0744f06d14e90d0aae74d91a1953056c27a186c793bc104c22f832
pkgname = python-webssh
-
diff --git a/PKGBUILD b/PKGBUILD
index 5bf8ce67df1f..1532313c2f92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,44 @@
-# Maintainer: Moritz Patelscheck <moritz(at)patelscheck.de>
-_name=webssh
-pkgname=python-$_name
-pkgver=1.5.3
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contribubtor: Moritz Patelscheck <moritz(at)patelscheck.de>
+
+pkgname=python-webssh
+_pkg="${pkgname#python-}"
+pkgver=1.6.1
pkgrel=1
-pkgdesc="A SSH Web Front End"
-arch=(any)
+pkgdesc="Web-based SSH client"
+arch=('any')
url="https://github.com/huashengdun/webssh"
-license=("Apache")
-depends=("python-tornado" "python-paramiko")
-makedepends=("python" "python-setuptools")
-backup=(etc/conf.d/webssh)
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
+license=('MIT')
+depends=('python-paramiko' 'python-tornado')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+checkdepends=('python-pytest')
+backup=('etc/conf.d/webssh')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/w/$_pkg/$_pkg-$pkgver.tar.gz"
webssh.conf.d
- webssh.service
- sysusers.conf)
-sha256sums=('02ee8f13c8d89bc2e4129d01d72996fff664ae4715d016aec2e7d09ab1cb114e'
+ webssh.service
+ sysusers.conf)
+sha256sums=('83745141459b8c745a65155e92611372b1d8795208a5eb5e08287ba36f2304b6'
'd14c4c025468b8a4801b8f93dccad10da638934ec394bf34f9523bbcfe358286'
'cd7f5fc4b81fc1757fca6c00b5fadf1e24954d6c21682e6a3876b0de9e7be291'
'5f4eca9aeb0744f06d14e90d0aae74d91a1953056c27a186c793bc104c22f832')
build() {
- cd "$srcdir/$_name-$pkgver"
- python setup.py build
+ cd "$_pkg-$pkgver"
+ python -m build --wheel --no-isolation
}
-package() {
- cd "$srcdir/$_name-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+check() {
+ cd "$_pkg-$pkgver"
+ pytest -x
+}
- cd "$srcdir"
- # Configuration
- install -Dm644 webssh.conf.d "$pkgdir/etc/conf.d/webssh"
- install -Dm644 webssh.service \
- "$pkgdir/usr/lib/systemd/system/webssh.service"
- install -Dm644 sysusers.conf "$pkgdir/usr/lib/sysusers.d/webssh.conf"
+package() {
+ cd "$_pkg-$pkgver"
+ python -m installer --destdir "$pkgdir" dist/*.whl
+ local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
+ install -dv "$pkgdir/usr/share/licenses/$pkgname/"
+ ln -sv "$_site/$_pkg-$pkgver.dist-info/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dvm644 "$srcdir/$_pkg.conf.d" "$pkgdir/etc/conf.d/$_pkg"
+ install -Dvm644 "$srcdir/$_pkg.service" -t "$pkgdir/usr/lib/systemd/system/"
+ install -Dvm644 "$srcdir/sysusers.conf" "$pkgdir/usr/lib/sysusers.d/$_pkg.conf"
}