summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2022-01-23 22:13:37 +1100
committerMatthew Gamble2022-01-23 22:13:37 +1100
commitc1b13e54dcd653fa9d0f6687ef2001bb02d2180b (patch)
treef16c57fbc4cf66d0783124cb1ffd96e1af4fc37b
parentf1f76bcac41d587f7bdb5a2065e8f5a8fbeb1de6 (diff)
downloadaur-python-wire.tar.gz
Bump pkgrel for python3.10 rebuild, other cleanup
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD17
3 files changed, 19 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a33ce4de2f95..d3171ab6829d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = python-wire
pkgdesc = A convenience wrapper around the built-in SQLite3 module in python
pkgver = 1.0.0
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/djmattyg007/python-wire
arch = any
license = GPL3
makedepends = python-setuptools
depends = python
- source = https://github.com/djmattyg007/python-wire/archive/1.0.0.zip
- sha256sums = 0aaf5e3c280756fd723bf1b0fd68430da6f228d4b21a7eb9f9b18c33660bf978
+ source = https://github.com/djmattyg007/python-wire/archive/1.0.0.tar.gz
+ sha256sums = 4cc8766220b85ed228104b155a338de06acf4718bf300b0bbf5776bd5c72114b
pkgname = python-wire
-
diff --git a/.gitignore b/.gitignore
index 3adfa93ba7a6..fefba76be301 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
-*.zip
-*.pkg.tar.xz
/pkg/
/src/
+
+*.pkg.tar.*
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index b23a21d478af..aaee17eab46e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,27 @@
pkgname=python-wire
pkgver=1.0.0
-pkgrel=5
+pkgrel=6
pkgdesc="A convenience wrapper around the built-in SQLite3 module in python"
arch=("any")
url="https://github.com/djmattyg007/python-wire"
license=("GPL3")
depends=("python")
makedepends=("python-setuptools")
-source=("https://github.com/djmattyg007/python-wire/archive/${pkgver}.zip")
-sha256sums=("0aaf5e3c280756fd723bf1b0fd68430da6f228d4b21a7eb9f9b18c33660bf978")
+source=("https://github.com/djmattyg007/python-wire/archive/${pkgver}.tar.gz")
+sha256sums=("4cc8766220b85ed228104b155a338de06acf4718bf300b0bbf5776bd5c72114b")
+
+build() {
+ cd "python-wire-${pkgver}"
+
+ python setup.py build
+}
package() {
cd "python-wire-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1
+
+ PYTHONHASHSEED=0 python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/python-wire/LICENSE"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/python-wire/README.md"
}