summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2022-04-06 22:05:00 +1000
committerMatthew Gamble2022-04-06 22:05:00 +1000
commit221d523932581abffc422e4e0064adb622d6d67a (patch)
treead0f2108768612b0c9a3f01159f949db0c309260
parent52e2fd036d22518c654120f425c9eced4670ff72 (diff)
downloadaur-python-wsgidav.tar.gz
Resolve issue with missing files
- Switch to github tarball - Use a slightly newer commit with some bugfixes for 4.0.1 - Include the previously missing htdocs folder - Finally able to include the sample YAML config
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef653d07d89b..8f00646745fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-wsgidav
pkgdesc = Generic WebDAV server based on WSGI
pkgver = 4.0.1
- pkgrel = 1
+ pkgrel = 3
url = https://github.com/mar10/wsgidav
arch = any
license = MIT
@@ -15,12 +15,12 @@ pkgbase = python-wsgidav
optdepends = python-lxml: for faster XML processing
optdepends = python-cheroot: to use the built-in webserver
optdepends = python-pam: to use PAM for authentication
- source = https://pypi.io/packages/source/W/WsgiDAV/WsgiDAV-4.0.1.tar.gz
+ source = https://github.com/mar10/wsgidav/archive/d22ada5db70812ac9201c6861c53ce5cf2157342.tar.gz
source = uwsgi.py
source = uwsgi.ini
source = config.example.json
source = config.example.json5
- sha256sums = 7b28e3e7e604c5665e7e1b1188a8d39d6ee60e635297293d3a175798ba24eccd
+ sha256sums = 24f576ecbe7b4d0e33dceb5da167b1676a52a19541f7eb25582e02e7006aab07
sha256sums = 774ee839b5248d2614294daf2c8a28fda69f1524d8b5b61d9e75de7b9c986b4d
sha256sums = 25826e3ceec2e9e01c54e6367966537017b0c758c7eda131566a95f97b474250
sha256sums = 9e4d7e9ae9e56a5d0f14c91b296825114e57456888280e59dcf158dad36b9474
diff --git a/PKGBUILD b/PKGBUILD
index 1443b326108b..7ff41f33a8cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,8 @@
pkgname=python-wsgidav
pkgver=4.0.1
-pkgrel=2
+_commit_hash=d22ada5db70812ac9201c6861c53ce5cf2157342
+pkgrel=3
pkgdesc="Generic WebDAV server based on WSGI"
arch=("any")
license=("MIT")
@@ -15,14 +16,14 @@ optdepends=(
"python-pam: to use PAM for authentication"
)
source=(
- "https://pypi.io/packages/source/W/WsgiDAV/WsgiDAV-${pkgver}.tar.gz"
+ "https://github.com/mar10/wsgidav/archive/${_commit_hash}.tar.gz"
"uwsgi.py"
"uwsgi.ini"
"config.example.json"
"config.example.json5"
)
sha256sums=(
- "7b28e3e7e604c5665e7e1b1188a8d39d6ee60e635297293d3a175798ba24eccd"
+ "24f576ecbe7b4d0e33dceb5da167b1676a52a19541f7eb25582e02e7006aab07"
"774ee839b5248d2614294daf2c8a28fda69f1524d8b5b61d9e75de7b9c986b4d"
"25826e3ceec2e9e01c54e6367966537017b0c758c7eda131566a95f97b474250"
"9e4d7e9ae9e56a5d0f14c91b296825114e57456888280e59dcf158dad36b9474"
@@ -30,15 +31,17 @@ sha256sums=(
)
build() {
- cd "WsgiDAV-${pkgver}"
+ cd "wsgidav-${_commit_hash}"
python setup.py build
}
package() {
- cd "WsgiDAV-${pkgver}"
+ cd "wsgidav-${_commit_hash}"
- PYTHONHASHSEED=0 python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ local _site_packages=$(python -c "import site; print(site.getsitepackages()[0], end='')")
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
rm "${pkgdir}/usr/CHANGELOG.md"
+ cp -r "wsgidav/dir_browser/htdocs" "${pkgdir}${_site_packages}/wsgidav/dir_browser/"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/python-wsgidav/LICENSE"
install -Dm644 README.md "${pkgdir}/usr/share/doc/python-wsgidav/README.md"
@@ -48,6 +51,5 @@ package() {
install -Dm644 "${srcdir}/uwsgi.ini" "${pkgdir}/usr/share/python-wsgidav/uwsgi.ini"
install -Dm644 "${srcdir}/config.example.json" "${pkgdir}/usr/share/python-wsgidav/config.example.json"
install -Dm644 "${srcdir}/config.example.json5" "${pkgdir}/usr/share/python-wsgidav/config.example.json5"
- # Waiting on this issue to be resolved: https://github.com/mar10/wsgidav/issues/247
- #install -Dm644 "sample_wsgidav.yaml" "${pkgdir}/usr/share/python-wsgidav/config.example.yaml"
+ install -Dm644 "sample_wsgidav.yaml" "${pkgdir}/usr/share/python-wsgidav/config.example.yaml"
}