summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Powers2016-03-21 20:33:48 -0600
committerBenjamin Powers2016-03-21 20:33:48 -0600
commitad05bd83605428bd148e746d8182b1dc77bb807f (patch)
tree89c539237ea81ef310f56e206918bc944af9c046
downloadaur-python-wsgiref.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..45070cedd0d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Tue Mar 22 02:33:43 UTC 2016
+pkgbase = python-wsgiref
+ pkgdesc = This is a standalone release of the wsgiref library, that provides validation support for WSGI 1.0.1
+ pkgver = 0.1.2
+ pkgrel = 1
+ arch = any
+ license = PSF
+ license = ZPL
+ makedepends = python
+ makedepends = python-setuptools
+ source = https://pypi.python.org/packages/source/w/wsgiref/wsgiref-0.1.2.zip
+ md5sums = 29b146e6ebd0f9fb119fe321f7bcf6cb
+
+pkgname = python-wsgiref
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef541097e88d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+_pypiname=wsgiref
+pkgname=python-wsgiref
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="This is a standalone release of the wsgiref library, that provides validation support for WSGI 1.0.1"
+arch=(any)
+source=("https://pypi.python.org/packages/source/w/wsgiref/${_pypiname}-${pkgver}.zip")
+license=("PSF" "ZPL")
+makedepends=("python" "python-setuptools")
+md5sums=('29b146e6ebd0f9fb119fe321f7bcf6cb')
+
+prepare() {
+ cd "$_pypiname-${pkgver}"
+ 2to3 -w .
+}
+
+package() {
+ cd "$_pypiname-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}