summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-08-15 23:05:34 -0700
committerxiota2023-08-15 23:05:34 -0700
commitd4fd55cce85e71da20b3486899739d675132f15a (patch)
treea2d1751de3af2d12466979d9412bfc84eb7c6b79
parent3b9df860819dc38249e4a012397688b8750a749d (diff)
downloadaur-python-wxpython-dev.tar.gz
metapackage
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD45
3 files changed, 17 insertions, 60 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d0251a3a9fa..95f8c61471cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,9 @@
pkgbase = python-wxpython-dev
- pkgdesc = Cross-platform GUI toolkit. Developer version
- pkgver = 4.2.1a1.dev5556+2f2624b1
- pkgrel = 2
- url = https://www.wxpython.org
- arch = x86_64
- license = custom:wxWindows
- checkdepends = xorg-server-xvfb
- checkdepends = python-pytest-forked
- checkdepends = python-numpy
- makedepends = mesa
- makedepends = glu
- makedepends = webkit2gtk
- makedepends = python-requests
- makedepends = python-setuptools
- makedepends = python-attrdict
- depends = wxwidgets-gtk3
- depends = python-six
- optdepends = python-pypubsub: Alternative to the deprecated wx.lib.pubsub API
- provides = python-wxpython
- conflicts = python-wxpython
- source = https://wxpython.org/Phoenix/snapshot-builds/wxPython-4.2.1a1.dev5556+2f2624b1.tar.gz
- sha512sums = 95c1eda2431129521c4a0b05344d249d14da252dc91653c12617973144c8e96602f99f357e99da78de1d75ce87f7493491d3bde05bca51a1388fd4379cc48677
+ pkgdesc = metapackage - migrate to python-wxpython-git
+ pkgver = 0.0.1
+ pkgrel = 1
+ epoch = 1
+ arch = any
pkgname = python-wxpython-dev
+ depends = python-wxpython-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index bd90d5f8579e..c65af2f57269 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,12 @@
-# Maintainer: Yu-Hsuan Tu <dobe0331 at gmail dot com>
-# Contributor: Qirui Wang <wqr.prg@gmail.com>
-# Contributor: Filipe Laíns (FFY00) <lains@archlinux.org>
-# Contributor: Morten Linderud <foxboron@archlinux.org>
-# Contributor: Eric Bélanger <eric@archlinux.org>
+# Maintainer:
pkgname=python-wxpython-dev
-_pkgname=wxPython
-pkgver=4.2.1a1.dev5556+2f2624b1
-pkgrel=2
-pkgdesc='Cross-platform GUI toolkit. Developer version'
-arch=('x86_64')
-license=('custom:wxWindows')
-url='https://www.wxpython.org'
-depends=('wxwidgets-gtk3' 'python-six')
-optdepends=('python-pypubsub: Alternative to the deprecated wx.lib.pubsub API')
-makedepends=('mesa' 'glu' 'webkit2gtk' 'python-requests' 'python-setuptools' 'python-attrdict')
-checkdepends=('xorg-server-xvfb' 'python-pytest-forked' 'python-numpy')
-provides=('python-wxpython')
-conflicts=('python-wxpython')
-source=("https://wxpython.org/Phoenix/snapshot-builds/wxPython-$pkgver.tar.gz")
-sha512sums=('95c1eda2431129521c4a0b05344d249d14da252dc91653c12617973144c8e96602f99f357e99da78de1d75ce87f7493491d3bde05bca51a1388fd4379cc48677')
-
-build() {
- cd "$_pkgname-$pkgver"
- python build.py dox etg --nodoc build --release
-}
-
-check() {
- cd "$_pkgname-$pkgver"
-
- # there are segfaulting tests so --forked ensures we get sensible results
- PYTHONPATH=$PWD xvfb-run pytest --forked unittests || echo "==> WARNING: tests usually fail randomly"
-}
+pkgver=0.0.1
+pkgrel=1
+epoch=1
+pkgdesc='metapackage - migrate to python-wxpython-git'
+arch=('any')
package() {
- cd "$_pkgname-$pkgver"
-
- python build.py install --destdir="$pkgdir"
-
- install -Dm 644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
- find "$pkgdir/usr/lib" -type f | xargs chmod 644
+ depends=(python-wxpython-git)
}