summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2021-08-04 19:11:21 +0300
committerPekka Ristola2021-08-04 19:11:21 +0300
commitd0a3ec7ed1ab23490870949d3e330060fddadebb (patch)
tree1b032afda292a2dbbf0ab348154f1c5ec36c443b
parentdbd89811570a06b939528d0250f4d7bf5ec74a2d (diff)
downloadaur-d0a3ec7ed1ab23490870949d3e330060fddadebb.tar.gz
Update to 0.19.0 and clean up the PKGBUILD
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
2 files changed, 13 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd6e7e4d037c..8ae5a2f7bb91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = python-ytmusicapi
- pkgdesc = Unofficial API for YouTube Music.
- pkgver = 0.18.0
+ pkgdesc = Unofficial API for YouTube Music
+ pkgver = 0.19.0
pkgrel = 1
url = https://github.com/sigma67/ytmusicapi
arch = any
license = MIT
depends = python-setuptools
depends = python-requests
- source = https://pypi.io/packages/source/y/ytmusicapi/ytmusicapi-0.18.0.tar.gz
- source = ytmusicapi-0.18.0-LICENSE::https://raw.githubusercontent.com/sigma67/ytmusicapi/0.18.0/LICENSE
- sha512sums = 15cf1559c94f12609b7fe5dd9ef1221ba5933d5c8ded99cb12546ec3b58004f9cdcd2fb9c3db2dca0dd23a95f016cc56749d1fbdf79e94e927c71c503985c701
- sha512sums = 205d1ad949dbce9cbd5a3631ba2a9f7a06117cb7745870fcb201ad649e6ef987c8c5f8d791a5509a15a0918b65d7af59ab6d502b1804ccfe2a3026f9f0004468
+ source = https://files.pythonhosted.org/packages/source/y/ytmusicapi/ytmusicapi-0.19.0.tar.gz
+ sha256sums = e95216365952d5e1f50cc5af00966bf2c35d8eaf34a694ae0cfb715d25cc3deb
pkgname = python-ytmusicapi
diff --git a/PKGBUILD b/PKGBUILD
index cda9f53592f9..443296fe8dff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
# Contributor: Tim Schumacher <timschumi@gmx.de>
pkgname=python-ytmusicapi
-pkgver=0.18.0
+pkgver=0.19.0
pkgrel=1
-pkgdesc="Unofficial API for YouTube Music."
+pkgdesc="Unofficial API for YouTube Music"
arch=('any')
-license=('MIT')
url="https://github.com/sigma67/ytmusicapi"
+license=('MIT')
depends=('python-setuptools' 'python-requests')
-source=("https://pypi.io/packages/source/y/ytmusicapi/ytmusicapi-$pkgver.tar.gz"
- "ytmusicapi-${pkgver}-LICENSE::https://raw.githubusercontent.com/sigma67/ytmusicapi/$pkgver/LICENSE")
-sha512sums=('15cf1559c94f12609b7fe5dd9ef1221ba5933d5c8ded99cb12546ec3b58004f9cdcd2fb9c3db2dca0dd23a95f016cc56749d1fbdf79e94e927c71c503985c701'
- '205d1ad949dbce9cbd5a3631ba2a9f7a06117cb7745870fcb201ad649e6ef987c8c5f8d791a5509a15a0918b65d7af59ab6d502b1804ccfe2a3026f9f0004468')
+_name=${pkgname#python-}
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('e95216365952d5e1f50cc5af00966bf2c35d8eaf34a694ae0cfb715d25cc3deb')
build() {
cd ytmusicapi-$pkgver
@@ -20,9 +20,9 @@ build() {
package() {
cd ytmusicapi-$pkgver
- python setup.py install --root="$pkgdir" --optimize=1
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
install -Dvm644 'README.rst' -t "${pkgdir}/usr/share/doc/${pkgname}"
- install -Dvm644 "$srcdir/ytmusicapi-${pkgver}-LICENSE" -T "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dvm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
}