summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormar77i2016-02-12 11:00:06 +0100
committermar77i2016-02-12 11:00:06 +0100
commitc227ab7a72be082866e8357074925a7138773791 (patch)
tree2dd3ce37a447b46324d92560d8726d58bd2668d6
downloadaur-python-zzzeeksphinx.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD17
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..239284d58c2d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Fri Feb 12 09:59:53 UTC 2016
+pkgbase = python-zzzeeksphinx
+ pkgdesc = This is zzzeek's own Sphinx layout, used by SQLAlchemy.
+ pkgver = 1.0.18
+ pkgrel = 1
+ url = https://bitbucket.org/zzzeek/zzzeeksphinx
+ arch = any
+ license = MIT
+ depends = python-pyscss
+ depends = python-mako
+ source = https://pypi.python.org/packages/source/z/zzzeeksphinx/zzzeeksphinx-1.0.18.tar.gz
+ sha1sums = a991c0d72c29bb2d0eda213f3a10db59803652dd
+
+pkgname = python-zzzeeksphinx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3dc45177d957
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: mar77i <mar77i at mar77i dot ch>
+_basepkg=zzzeeksphinx
+pkgname="python-$_basepkg"
+pkgver=1.0.18
+pkgrel=1
+pkgdesc="This is zzzeek's own Sphinx layout, used by SQLAlchemy."
+arch=(any)
+url="https://bitbucket.org/zzzeek/$_basepkg"
+license=('MIT')
+depends=('python-pyscss' 'python-mako')
+source=("https://pypi.python.org/packages/source/${_basepkg:0:1}/$_basepkg/$_basepkg-$pkgver.tar.gz")
+sha1sums=(a991c0d72c29bb2d0eda213f3a10db59803652dd)
+
+package() {
+ cd "$srcdir/$_basepkg-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}