summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTruocolo2023-12-21 20:48:40 +0100
committerTruocolo2023-12-21 20:48:40 +0100
commit1b20fb9efd3fec52561a6d4ce0a02c38aee0fd18 (patch)
treea93e8402cce57dfcbff59fd9aa3b668c33513da6
parent327b8b093edde7fb67e6f27049fa7620bc76a65c (diff)
downloadaur-python2-beautifulsoup4.tar.gz
update style for last stable
-rw-r--r--PKGBUILD41
1 files changed, 31 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 27a4ab4d015a..7c97ff2a5bd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,24 +23,45 @@ makedepends=(
'python2-setuptools'
)
_tarname="${_distname}-${pkgver}"
-source=("https://files.pythonhosted.org/packages/source/${_distname::1}/${_distname}/${_tarname}.tar.gz")
-sha256sums=('84729e322ad1d5b4d25f805bfa05b902dd96450f43842c4e99067d5e1369eb25')
+source=(
+ "https://files.pythonhosted.org/packages/source/${_distname::1}/${_distname}/${_tarname}.tar.gz")
+sha256sums=(
+ '84729e322ad1d5b4d25f805bfa05b902dd96450f43842c4e99067d5e1369eb25')
_sourcedirectory="$_distname-$pkgver"
build() {
- cd "${_tarname}"
- python2 setup.py build
+ cd \
+ "${_tarname}"
+ python2 \
+ setup.py \
+ build
}
check() {
- cd "${_tarname}"
- python2 -m unittest discover -s bs4 -v
+ cd \
+ "${_tarname}"
+ python2 \
+ -m unittest \
+ discover \
+ -s bs4 \
+ -v
}
package() {
- cd "${_tarname}"
- python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
-
- install -Dm 644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ cd \
+ "${_tarname}"
+ python2 \
+ setup.py \
+ install \
+ --root="${pkgdir}" \
+ --optimize=1 \
+ --skip-build
+
+ install \
+ -Dm 644 \
+ 'LICENSE' \
+ -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
+
+# vim: ft=sh syn=sh et