summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Sampson2015-06-21 20:18:53 +1000
committerMike Sampson2015-06-21 20:18:53 +1000
commitfcdfa9d00fd4da20fb4e919669338afe3e2bc81e (patch)
treee6a768ce6d9077e3d392b5b8e431dc24e10b0f45
downloadaur-python2-calabash.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
-rw-r--r--UNLICENSE24
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fd7f19704f36
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-calabash
+ pkgdesc = Bash-style pipelining syntax for Python generators.
+ pkgver = 0.0.3
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/calabash
+ arch = any
+ license = CUSTOM
+ depends = python2
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/c/calabash/calabash-0.0.3.tar.gz
+ source = UNLICENSE
+ md5sums = 83480435d2d0dfa6e63ba450540a8d6e
+ md5sums = 7246f848faa4e9c9fc0ea91122d6e680
+
+pkgname = python2-calabash
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d82b3d353f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Mike Sampson <mike@sambodata.com>
+pkgname=python2-calabash
+pkgver=0.0.3
+pkgrel=1
+pkgdesc="Bash-style pipelining syntax for Python generators."
+arch=('any')
+url="http://pypi.python.org/pypi/calabash"
+license=('CUSTOM')
+groups=()
+depends=('python2')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=('https://pypi.python.org/packages/source/c/calabash/calabash-0.0.3.tar.gz' 'UNLICENSE')
+md5sums=('83480435d2d0dfa6e63ba450540a8d6e'
+ '7246f848faa4e9c9fc0ea91122d6e680')
+
+package() {
+ cd "$srcdir/calabash-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+
+ install -d $pkgdir/usr/share/licenses/python2-calabash
+ install -m 644 -t $pkgdir/usr/share/licenses/python2-calabash/ $srcdir/UNLICENSE
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/UNLICENSE b/UNLICENSE
new file mode 100644
index 000000000000..68a49daad8ff
--- /dev/null
+++ b/UNLICENSE
@@ -0,0 +1,24 @@
+This is free and unencumbered software released into the public domain.
+
+Anyone is free to copy, modify, publish, use, compile, sell, or
+distribute this software, either in source code form or as a compiled
+binary, for any purpose, commercial or non-commercial, and by any
+means.
+
+In jurisdictions that recognize copyright laws, the author or authors
+of this software dedicate any and all copyright interest in the
+software to the public domain. We make this dedication for the benefit
+of the public at large and to the detriment of our heirs and
+successors. We intend this dedication to be an overt act of
+relinquishment in perpetuity of all present and future rights to this
+software under copyright law.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY CLAIM, DAMAGES OR
+OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+OTHER DEALINGS IN THE SOFTWARE.
+
+For more information, please refer to <http://unlicense.org/>