summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGilles Hamel2017-11-14 21:52:20 +0100
committerGilles Hamel2017-11-14 21:52:20 +0100
commite0c3d139b8b8317748aac61d925e51919ad7ace4 (patch)
tree360c35efc2635b6acda2de08873e6f86b602f403
parent583b32d25250651759f4c35e14a578a1ea6f7f9a (diff)
downloadaur-e0c3d139b8b8317748aac61d925e51919ad7ace4.tar.gz
Merge upstream config file
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--carbon.conf40
3 files changed, 43 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e9efc40e357..32af71731452 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Nov 14 19:56:08 UTC 2017
+# Tue Nov 14 20:51:41 UTC 2017
pkgbase = python2-carbon
pkgdesc = Backend data caching and persistence daemon for Graphite
pkgver = 1.0.2
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/graphite-project/carbon
arch = any
license = Apache
@@ -27,7 +27,7 @@ pkgbase = python2-carbon
source = carbon.conf
md5sums = 5dacf9b12c4d76d76ac3b3bc7409e243
md5sums = 5305b294d608a62945d5fc11854e25cd
- md5sums = b639b742d1e9663c93f8a22a3d56e424
+ md5sums = 4b6d054aed3304af567552782b72ea8b
pkgname = python2-carbon
diff --git a/PKGBUILD b/PKGBUILD
index f0ef02c74667..534d2e84274a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
Maintainer='Gilles Hamel <hamelg@laposte.net>'
pkgname=python2-carbon
pkgver=1.0.2
-pkgrel=2
+pkgrel=3
pkgdesc='Backend data caching and persistence daemon for Graphite'
arch=('any')
url='https://github.com/graphite-project/carbon'
@@ -12,7 +12,7 @@ optdepends=('python2-txamqp: AMQP support')
makedepends=('python2-setuptools')
options=(!emptydirs)
source=("https://github.com/graphite-project/carbon/archive/$pkgver.tar.gz" carbon.service carbon.conf)
-md5sums=(5dacf9b12c4d76d76ac3b3bc7409e243 5305b294d608a62945d5fc11854e25cd b639b742d1e9663c93f8a22a3d56e424)
+md5sums=(5dacf9b12c4d76d76ac3b3bc7409e243 5305b294d608a62945d5fc11854e25cd 4b6d054aed3304af567552782b72ea8b)
backup=(etc/carbon/aggregation-rules.conf etc/carbon/blacklist.conf etc/carbon/carbon.amqp.conf etc/carbon/carbon.conf etc/carbon/relay-rules.conf etc/carbon/rewrite-rules.conf etc/carbon/storage-aggregation.conf etc/carbon/storage-schemas.conf etc/carbon/whitelist.conf)
package() {
diff --git a/carbon.conf b/carbon.conf
index 7e27c719e4d9..ab43cd3ed8e9 100644
--- a/carbon.conf
+++ b/carbon.conf
@@ -36,8 +36,8 @@ WHITELISTS_DIR = /var/lib/carbon/lists/
# files of arbitrary fixed-size resolutions.
DATABASE = whisper
-# Enable daily log rotation. If disabled, carbon will automatically re-open
-# the file if it's rotated out of place (e.g. by logrotate daemon)
+# Enable daily log rotation. If disabled, a new file will be opened whenever the log file path no
+# longer exists (i.e. it is removed or renamed)
ENABLE_LOGROTATION = True
# Specify the user to drop privileges to
@@ -80,6 +80,12 @@ MAX_CREATES_PER_MINUTE = 50
# second.
MIN_TIMESTAMP_RESOLUTION = 1
+# Set the minimum lag in seconds for a point to be written to the database
+# in order to optimize batching. This means that each point will wait at least
+# the duration of this lag before being written. Setting this to 0 disable the feature.
+# This currently only works when using the timesorted write strategy.
+# MIN_TIMESTAMP_LAG = 0
+
# Set the interface and port for the line (plain text) listener. Setting the
# interface to 0.0.0.0 listens on all interfaces. Port can be set to 0 to
# disable this listener if it is not required.
@@ -291,6 +297,16 @@ WHISPER_FALLOCATE_CREATE = True
# Example: store everything
# BIND_PATTERNS = #
+# URL of graphite-web instance, this is used to add incoming series to the tag database
+# GRAPHITE_URL = http://127.0.0.1:8000
+
+# Tag support, when enabled carbon will make HTTP calls to graphite-web to update the tag index
+# ENABLE_TAGS = True
+
+# Tag update interval, this specifies how frequently updates to existing series will trigger
+# an update to the tag index, the default setting is once every 100 updates
+# TAG_UPDATE_INTERVAL = 100
+
# To configure special settings for the carbon-cache instance 'b', uncomment this:
#[cache:b]
#LINE_RECEIVER_PORT = 2103
@@ -365,6 +381,17 @@ DESTINATIONS = 127.0.0.1:2004
# extended with CarbonClientFactory plugins and defaults to "pickle".
# DESTINATION_PROTOCOL = pickle
+# When using consistent hashing it sometime makes sense to make
+# the ring dynamic when you don't want to loose points when a
+# single destination is down. Replication is an answer to that
+# but it can be quite expensive.
+# DYNAMIC_ROUTER = False
+
+# Controls the number of connection attempts before marking a
+# destination as down. We usually do one connection attempt per
+# second.
+# DYNAMIC_ROUTER_MAX_RETRIES = 5
+
# This is the maximum number of datapoints that can be queued up
# for a single destination. Once this limit is hit, we will
# stop accepting new data if USE_FLOW_CONTROL is True, otherwise
@@ -554,3 +581,12 @@ MAX_AGGREGATION_INTERVALS = 5
# Specify the user to drop privileges to
# If this is blank carbon-aggregator runs as the user that invokes it
# USER =
+
+# Part of the code, and particularly aggregator rules, need
+# to cache metric names. To avoid leaking too much memory you
+# can tweak the size of this cache. The default allow for 1M
+# different metrics per rule (~200MiB).
+# CACHE_METRIC_NAMES_MAX=1000000
+
+# You can optionally set a ttl to this cache.
+# CACHE_METRIC_NAMES_TTL=600