summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-06-09 11:41:58 -0700
committerAndy Weidenbaum2015-06-09 11:41:58 -0700
commit3716a6ee9203659db79987597b393ab2793649b4 (patch)
tree375a1c0a390a956ac95ace94ab4f1845bc89617e
downloadaur-python2-cube-client.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e228ffb831c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-cube-client
+ pkgdesc = A Python client for Cube: Time Series Data Collection & Analysis
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/tsileo/cube-client
+ arch = any
+ license = MIT
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-requests
+ optdepends = cube-git: Time series data collection & analysis
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/c/cube-client/cube-client-0.2.0.tar.gz
+ md5sums = db789558ee0ee1a6d5eeed1dc5e58196
+ sha256sums = 55c397d335b9e20afa8cc0279f49e35d0e78780919e465c4d0e1dc30532ea10f
+
+pkgname = python2-cube-client
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5fed3ba4936d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=python2-cube-client
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="A Python client for Cube: Time Series Data Collection & Analysis"
+arch=('any')
+depends=('python2' 'python2-requests')
+makedepends=('python2-setuptools')
+optdepends=('cube-git: Time series data collection & analysis')
+url="https://github.com/tsileo/cube-client"
+license=('MIT')
+options=(!emptydirs)
+source=(https://pypi.python.org/packages/source/c/${pkgname#python2-}/${pkgname#python2-}-$pkgver.tar.gz)
+md5sums=('db789558ee0ee1a6d5eeed1dc5e58196')
+sha256sums=('55c397d335b9e20afa8cc0279f49e35d0e78780919e465c4d0e1dc30532ea10f')
+
+prepare(){
+ cd $srcdir/${pkgname#python2-}-$pkgver
+
+ msg 'Fixing Python version...'
+ find . -type f -print0 | xargs -0 sed -i 's#/usr/bin/python#/usr/bin/python2#g'
+ find . -type f -print0 | xargs -0 sed -i 's#/usr/bin/env python#/usr/bin/env python2#g'
+}
+
+build() {
+ cd $srcdir/${pkgname#python2-}-$pkgver
+
+ msg 'Building...'
+ python2 setup.py build
+}
+
+package() {
+ cd $srcdir/${pkgname#python2-}-$pkgver
+
+ msg 'Installing...'
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}