summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Straube2019-09-24 17:18:34 +0200
committerMichael Straube2019-09-24 17:18:34 +0200
commitc2028e2777e4c5210370efc2df294b4ddd8a2347 (patch)
treed6dfc803ca5042b31960cc2dac604a1a6b9151e7
downloadaur-python2-dominate.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a74d671bca56
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-dominate
+ pkgdesc = Python library for creating and manipulating HTML documents
+ pkgver = 2.4.0
+ pkgrel = 1
+ url = https://github.com/Knio/dominate
+ arch = any
+ license = LGPL3
+ checkdepends = python2-pytest-runner
+ makedepends = python2-setuptools
+ source = python2-dominate-2.4.0.tar.gz::https://github.com/Knio/dominate/archive/2.4.0.tar.gz
+ sha512sums = 93b721762175f14339d5b027af59d8475485b2674c019990bdc0989067448f4b74350d16b19c396ee2e514822930e821675f8bbab96e03be3e5899dd95a86ee4
+
+pkgname = python2-dominate
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c588e95e9ec3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer:
+
+pkgname=python2-dominate
+pkgver=2.4.0
+pkgrel=1
+pkgdesc="Python library for creating and manipulating HTML documents"
+arch=('any')
+url="https://github.com/Knio/dominate"
+license=('LGPL3')
+makedepends=('python2-setuptools')
+checkdepends=('python2-pytest-runner')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/Knio/dominate/archive/$pkgver.tar.gz")
+sha512sums=('93b721762175f14339d5b027af59d8475485b2674c019990bdc0989067448f4b74350d16b19c396ee2e514822930e821675f8bbab96e03be3e5899dd95a86ee4')
+
+build() {
+ cd dominate-$pkgver
+ python2 setup.py build
+}
+
+check() {
+ cd dominate-$pkgver
+ python2 setup.py pytest
+}
+
+package() {
+ cd dominate-$pkgver
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}