summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordrrossum2017-10-30 11:19:15 +0100
committerdrrossum2017-10-30 11:19:15 +0100
commit20df59972221046dfcec5b7423c022085789520c (patch)
tree4d92ecc1efa6f32fd25812013c805eee8d9093d8
parent8e66e5681689ef7a234c1354d3d9383e9c9869a5 (diff)
downloadaur-20df59972221046dfcec5b7423c022085789520c.tar.gz
change source to github and update to version 0.18.5
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 66ca3c47a385..456b98daa335 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
# Generated by mksrcinfo v8
-# Fri Sep 15 19:55:24 UTC 2017
+# Mon Oct 30 10:18:47 UTC 2017
pkgbase = python2-dulwich
pkgdesc = Pure-Python implementation of the Git file formats and protocols
- pkgver = 0.18.3
+ pkgver = 0.18.5
pkgrel = 1
url = https://www.dulwich.io/
arch = any
license = GPL2
options = !emptydirs
- source = https://www.dulwich.io/releases/dulwich-0.18.3.tar.gz
- source = https://www.dulwich.io/releases/dulwich-0.18.3.tar.gz.asc
- sha256sums = d34c2628f89a5ac632fa462b2edd5afcfbf512793cfa14452d4c52f786962a8a
- sha256sums = SKIP
+ source = https://github.com/jelmer/dulwich/archive/upstream/0.18.5.tar.gz
+ md5sums = 96e7a12f745c1f00c2923cac8e1efa0d
pkgname = python2-dulwich
depends = python2
diff --git a/PKGBUILD b/PKGBUILD
index 62bbad8318c4..2de2c8468eb4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Timothée Ravier <tim@siosm.fr>
pkgname=(python2-dulwich python-dulwich)
-pkgver=0.18.3
+pkgver=0.18.5
pkgrel=1
pkgdesc='Pure-Python implementation of the Git file formats and protocols'
arch=('any')
@@ -9,13 +9,11 @@ url='https://www.dulwich.io/'
license=('GPL2')
depends=()
options=(!emptydirs)
-source=("https://www.dulwich.io/releases/dulwich-${pkgver}.tar.gz"{,.asc})
-validpgpkeys=('DC837EE14A7E37347E87061700806F2BD729A457') # Jelmer Vernooij
-sha256sums=('d34c2628f89a5ac632fa462b2edd5afcfbf512793cfa14452d4c52f786962a8a'
- 'SKIP')
+source=("https://github.com/jelmer/dulwich/archive/upstream/${pkgver}.tar.gz")
+
build() {
- cd "dulwich-${pkgver}"
+ cd "dulwich-upstream-${pkgver}"
python2 setup.py build
python setup.py build
}
@@ -23,15 +21,17 @@ build() {
package_python-dulwich() {
depends=('python')
conflicts=('python2-dulwich')
- cd "dulwich-${pkgver}"
+ cd "dulwich-upstream-${pkgver}"
python setup.py install --root="$pkgdir/" --skip-build --optimize=1
}
package_python2-dulwich() {
depends=('python2')
conflicts=('python-dulwich')
- cd "dulwich-${pkgver}"
+ cd "dulwich-upstream-${pkgver}"
python2 setup.py install --root="$pkgdir/" --skip-build --optimize=1
}
# vim:set ts=2 sw=2 et:
+
+md5sums=('96e7a12f745c1f00c2923cac8e1efa0d')