summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordrrossum2015-07-29 12:48:08 -0500
committerdrrossum2015-07-29 12:48:08 -0500
commitae5a3fe55aeb5b2994b974b5935020aac2b96972 (patch)
treec444768f2adbba33c565ee0c1cebd9774072eb04
downloadaur-ae5a3fe55aeb5b2994b974b5935020aac2b96972.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD16
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f442c4142568
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-dulwich
+ pkgdesc = Dulwich is a pure-Python implementation of the Git file formats and protocols.
+ pkgver = 0.9.7
+ pkgrel = 1
+ url = http://samba.org/~jelmer/dulwich/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = python2
+ source = https://pypi.python.org/packages/source/d/dulwich/dulwich-0.9.7.tar.gz
+ sha1sums = 0823f65c77ac75372560a5336c8e593725b05944
+
+pkgname = python2-dulwich
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ba9f0aa98d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+pkgname=python2-dulwich
+pkgver=0.9.7
+pkgrel=1
+pkgdesc="Dulwich is a pure-Python implementation of the Git file formats and protocols."
+arch=('i686' 'x86_64')
+url="http://samba.org/~jelmer/dulwich/"
+license=('GPL2')
+depends=('python2')
+
+source=("https://pypi.python.org/packages/source/d/dulwich/dulwich-$pkgver.tar.gz")
+sha1sums=("0823f65c77ac75372560a5336c8e593725b05944")
+
+package() {
+ cd "$srcdir/dulwich-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}