summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSigmund2015-06-16 20:36:34 +0100
committerSigmund2015-06-16 20:36:34 +0100
commitbc1fc0c86c07054faea68b8b3ba13d257118e7e5 (patch)
treedf9a391f48a78fea21ee13a4dc1a5db2cee4cf38
downloadaur-python2-eve-git.tar.gz
First commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd0ff21627ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-eve-git
+ pkgdesc = An open source Python REST API framework designed for human beings.
+ pkgver = 0.5.r176.g53107c9
+ pkgrel = 1
+ url = http://python-eve.org/
+ arch = any
+ license = BSD
+ makedepends = git
+ makedepends = python2-setuptools
+ provides = python2-eve
+ conflicts = python2-eve
+ options = !emptydirs
+ source = git+https://github.com/nicolaiarocci/eve.git
+ sha256sums = SKIP
+
+pkgname = python2-eve-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6dc4e9d7ebd0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Sigmund Vestergaard <sigmundv at gmail dot com>
+pkgname=python2-eve-git
+pkgver=0.5.r176.g53107c9
+pkgrel=1
+pkgdesc="An open source Python REST API framework designed for human beings."
+arch=('any')
+url="http://python-eve.org/"
+license=('BSD')
+makedepends=('git' 'python2-setuptools')
+conflicts=('python2-eve')
+provides=('python2-eve')
+options=(!emptydirs)
+source=("git+https://github.com/nicolaiarocci/eve.git")
+_repname=eve
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_repname"
+ # cutting off 'v' prefix that presents in the git tag
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$_repname"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: