summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitriy Morozov2015-06-23 09:54:49 -0700
committerDmitriy Morozov2015-06-23 09:54:49 -0700
commitbaa6612e155fc30169218143d753cec17cfafaec (patch)
tree9c2ebef95f2d432e81f0f12fa28e556fc2d96aa7
downloadaur-python2-fastcluster.tar.gz
Initial commit for AUR4
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c19e89faa9dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-fastcluster
+ pkgdesc = Fast hierarchical clustering routines for Python
+ pkgver = 1.1.13
+ pkgrel = 1
+ url = http://danifold.net/fastcluster.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python2
+ depends = python2-numpy
+ source = https://pypi.python.org/packages/source/f/fastcluster/fastcluster-1.1.13.tar.gz
+ md5sums = ca2a5f5e8ab81628c72ed2cc0e1e21c6
+
+pkgname = python2-fastcluster
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3351120e0443
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Dmitriy Morozov <archlinux@foxcub.org>
+pkgname=python2-fastcluster
+_pkgname=fastcluster
+pkgver=1.1.13
+pkgrel=1
+pkgdesc="Fast hierarchical clustering routines for Python"
+url="http://danifold.net/fastcluster.html"
+arch=('i686' 'x86_64')
+license="GPL"
+depends=('python2' 'python2-numpy')
+source=("https://pypi.python.org/packages/source/f/$_pkgname/$_pkgname-${pkgver}.tar.gz")
+md5sums=('ca2a5f5e8ab81628c72ed2cc0e1e21c6')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ python2 setup.py install --prefix=/usr --root="$pkgdir/"
+}