summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-08-25 15:21:43 -0700
committerAndy Weidenbaum2015-08-25 15:21:43 -0700
commit5c107985fb67bd6da45422d6a4719cf345a43a9d (patch)
tree132f2e5007d19a8ec8c8f2c210ebcc09adc10168
downloadaur-python2-getch.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a5778cf190e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-getch
+ pkgdesc = Functions to read one single char from standard input without waiting for a newline
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/getch
+ arch = i686
+ arch = x86_64
+ license = Unknown
+ makedepends = python2-setuptools
+ depends = python2
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/g/getch/getch-1.0-python2.tar.gz
+ md5sums = 586ea0f1f16aa094ff6a30736ba03c50
+ sha256sums = be451438f7a2b389f96753aea39b6ed2540a390f1b9a12badcbc110cf9a5ce7f
+
+pkgname = python2-getch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..933afdd2cc77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=python2-getch
+pkgver=1.0
+pkgrel=1
+pkgdesc="Functions to read one single char from standard input without waiting for a newline"
+arch=('i686' 'x86_64')
+depends=('python2')
+makedepends=('python2-setuptools')
+url="https://pypi.python.org/pypi/getch"
+license=('Unknown')
+options=(!emptydirs)
+source=(https://pypi.python.org/packages/source/g/${pkgname#python2-}/${pkgname#python2-}-$pkgver-python2.tar.gz)
+md5sums=('586ea0f1f16aa094ff6a30736ba03c50')
+sha256sums=('be451438f7a2b389f96753aea39b6ed2540a390f1b9a12badcbc110cf9a5ce7f')
+
+package() {
+ cd "$srcdir/${pkgname#python2-}-$pkgver"
+
+ msg 'Installing...'
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}