summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2019-09-26 17:49:59 -0400
committerSolomon Choina2019-09-26 17:49:59 -0400
commitbae899216ef2af0dbb149d59fa5fc16ab3c7e500 (patch)
treed76ff57fa896f245a114bc35956629411f9d1955
downloadaur-python2-graph.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..691ed2a8d924
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-graph
+ pkgdesc = A library for working with graphs in Python.
+ pkgver = 1.8.5
+ pkgrel = 1
+ url = https://github.com/shoobx/python-graph
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python2
+ makedepends = python2-setuptools
+ depends = python2
+ source = python2-graph-1.8.5::git+https://github.com/Shoobx/python-graph#commit=943ebbad7fa8e1ad69a37ef64bf525032077b8b9
+ sha512sums = SKIP
+
+pkgname = python2-graph
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b124d7ee7ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Thore Bödecker <foxxx0@archlinux.org>
+# Contributor: Tim Meusel <tim@bastelfreak.de>
+pkgname="python2-graph"
+_pkgname="${pkgname#python2-}"
+pkgdesc='A library for working with graphs in Python.'
+pkgver=1.8.5
+pkgrel=1
+arch=('any')
+url='https://github.com/shoobx/python-graph'
+license=('MIT')
+depends=('python2')
+makedepends=('git' 'python2' 'python2-setuptools')
+source=("${pkgname}-${pkgver}::git+https://github.com/Shoobx/python-graph#commit=943ebbad7fa8e1ad69a37ef64bf525032077b8b9")
+sha512sums=('SKIP')
+
+prepare(){
+ # fix python interpreter for python2 stuff
+ find "${srcdir}/${pkgname}-${pkgver}" -type f -name '*.py' \
+ -exec sed -i 's|^#!/usr/bin/env python$|#!/usr/bin/env python2|1' {} +
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}/core"
+ python2 ./setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}/core"
+ python2 ./setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m644 ../"COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+}