summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2019-03-06 23:03:03 -0500
committerTed Alff2019-03-06 23:03:03 -0500
commita036c866ad53201d9929a43fed7b2b25c4ef15af (patch)
treee7be65256c2ed8c2058e3337685124ea91acc9fd
downloadaur-python2-keybinder2.tar.gz
Initial commit. Dropped from official repos.
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD30
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd59e226a6a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = python2-keybinder2
+ pkgdesc = Library for registering global keyboard shortcuts (Python 2 bindings)
+ pkgver = 0.3.1
+ pkgrel = 3
+ url = https://github.com/kupferlauncher/keybinder
+ arch = i686
+ arch = x86_64
+ arch = mips64el
+ arch = armv6h
+ arch = armv7h
+ arch = arm
+ arch = aarch64
+ license = GPL
+ makedepends = gobject-introspection
+ depends = pygtk
+ depends = libkeybinder2
+ options = !emptydirs
+ source = https://github.com/kupferlauncher/keybinder/releases/download/v0.3.1/keybinder-0.3.1.tar.gz
+ sha256sums = 879f07130ac64792ddb9fd758e6673119283bda37d75573787ae22af8684a240
+
+pkgname = python2-keybinder2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36c7f92c43dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: twa022 <twa022 at gmail dot com>
+
+_pkgname=keybinder
+pkgname=python2-keybinder2
+pkgver=0.3.1
+pkgrel=3
+pkgdesc='Library for registering global keyboard shortcuts (Python 2 bindings)'
+arch=('i686' 'x86_64' 'mips64el' 'armv6h' 'armv7h' 'arm' 'aarch64')
+url='https://github.com/kupferlauncher/keybinder'
+license=('GPL')
+depends=('pygtk' 'libkeybinder2')
+makedepends=('gobject-introspection')
+options=('!emptydirs')
+source=("https://github.com/kupferlauncher/${_pkgname}/releases/download/v${pkgver}/${_pkgname}-$pkgver.tar.gz")
+sha256sums=('879f07130ac64792ddb9fd758e6673119283bda37d75573787ae22af8684a240')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ ./configure --prefix=/usr PYTHON=python2 --disable-lua
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ make -C docs DESTDIR="${pkgdir}" uninstall
+ make -C libkeybinder DESTDIR="${pkgdir}" uninstall
+}
+