summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJörg Thalheim2015-06-11 15:46:19 +0200
committerJörg Thalheim2015-06-11 15:46:19 +0200
commitbf5638465aad4288bd7055436496fdb06c32b392 (patch)
tree57c2d85a86b867c0596fe40d8b8c621a74346b00
downloadaur-python2-lxc-git.tar.gz
Initial Import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD21
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..feb84a4ae4d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-lxc-git
+ pkgdesc = Python2 bindings for liblxc
+ pkgver = 20140610
+ pkgrel = 1
+ url = https://github.com/lxc/python2-lxc
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = git
+ makedepends = python2-distribute
+ depends = python2
+ depends = lxc
+ source = git+https://github.com/lxc/python2-lxc
+ sha1sums = SKIP
+
+pkgname = python2-lxc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff5a6c1cfe3e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+pkgname='python2-lxc-git'
+pkgrel=1
+pkgver=20140610
+pkgdesc="Python2 bindings for liblxc"
+depends=('python2' 'lxc')
+url="https://github.com/lxc/python2-lxc"
+makedepends=('git' 'python2-distribute')
+license=('GPL3')
+arch=('x86_64' 'i686')
+source=("git+https://github.com/lxc/python2-lxc")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/python2-lxc"
+ git log -1 --format='%cd' --date=short | tr -d -- '-'
+}
+
+package() {
+ cd "$srcdir/python2-lxc"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}