summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLiam Greenough2017-04-17 16:03:22 +1000
committerLiam Greenough2017-04-17 16:03:22 +1000
commita24bcc531aa6d6d699b1cff818f2b63081769721 (patch)
tree77af600b20341ac8f5f8719f35e18d5151fd924e
downloadaur-python2-midi.tar.gz
Initial commit.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e21fa2fe034
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-midi
+ pkgdesc = A feature-rich, hardware-independent MIDI toolkit for Python
+ pkgver = 0.2.3
+ pkgrel = 2
+ url = https://github.com/vishnubob/python-midi
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = python2-setuptools
+ makedepends = swig
+ depends = alsa-lib
+ depends = python2
+ source = python2-midi-0.2.3.tar.gz::https://github.com/vishnubob/python-midi/archive/v0.2.3.tar.gz
+ sha256sums = e40119ba1ae3bc129141bfd68ca0805aed9b82416a42ee9b2325d1be7e566428
+ sha512sums = 3c7612af7625328b3c7ccecf541ca74c8dacd482b3448593d22a349f904f8e42d9a6dbf00891833113e4a56b46d87981371076beb62ae907f44d89e99c40afc5
+
+pkgname = python2-midi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7cab890e3206
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Liam Greenough <beacon515@gmail.com>
+# Contributer: Limao Luo <luolimao+AUR@gmail.com>
+
+pkgname=python2-midi
+pkgver=0.2.3
+pkgrel=2
+pkgdesc="A feature-rich, hardware-independent MIDI toolkit for Python"
+arch=(i686 x86_64)
+url=https://github.com/vishnubob/python-midi
+license=(MIT)
+depends=(alsa-lib python2)
+makedepends=(python2-setuptools swig)
+source=($pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz)
+sha256sums=('e40119ba1ae3bc129141bfd68ca0805aed9b82416a42ee9b2325d1be7e566428')
+sha512sums=('3c7612af7625328b3c7ccecf541ca74c8dacd482b3448593d22a349f904f8e42d9a6dbf00891833113e4a56b46d87981371076beb62ae907f44d89e99c40afc5')
+
+build() {
+ cd ${pkgname//2}-$pkgver/
+ python2 setup.py build
+}
+
+
+package() {
+ cd ${pkgname//2}-$pkgver/
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}