summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron DeVore2015-07-08 11:18:52 -0700
committerAaron DeVore2015-07-08 11:18:52 -0700
commit81054d46112e73d7352c11436abe15a9478787a2 (patch)
treee037bac918f204e594a8787fbb54be7abc920048
downloadaur-python2-mongokit.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..28fd29fc9b2d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-mongokit
+ pkgdesc = Structured schema and validation layer on top of PyMongo
+ pkgver = 0.9.1.1
+ pkgrel = 1
+ url = http://namlook.github.com/mongokit/
+ arch = any
+ license = BSD
+ depends = python2
+ depends = python2-pymongo
+ source = http://pypi.python.org/packages/source/m/mongokit/mongokit-0.9.1.1.tar.gz
+ md5sums = 564c6af175b6cd8c2d3fa059e6900e88
+
+pkgname = python2-mongokit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd1263e93235
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Aaron DeVore <aaron.devore@gmail.com>
+# Contributor: Andrei Antoukh <niwi@niwi.be>
+
+pkgname=python2-mongokit
+pkgver=0.9.1.1
+pkgrel=1
+pkgdesc="Structured schema and validation layer on top of PyMongo"
+arch=('any')
+license=("BSD")
+url="http://namlook.github.com/mongokit/"
+depends=('python2' 'python2-pymongo')
+source=("http://pypi.python.org/packages/source/m/mongokit/mongokit-$pkgver.tar.gz")
+md5sums=('564c6af175b6cd8c2d3fa059e6900e88')
+
+build() {
+ cd "$srcdir/mongokit-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/mongokit-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ find "$pkgdir" -name "*.py" -exec \
+ sed -i '1s/python/python2/' {} \;
+
+ install -Dm 644 "$srcdir/mongokit-$pkgver/LICENSE" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+