summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRenato Coutinho2015-06-19 19:23:59 -0300
committerRenato Coutinho2015-06-19 19:23:59 -0300
commit6189de504fd5a7e5df5383b2b960816323379196 (patch)
treed80e5515b0b213b110911f5aabb580fdc164fbf9
downloadaur-python2-odespy-git.tar.gz
Initial import
-rw-r--r--.AURINFO23
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD35
3 files changed, 82 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..df3ac5254435
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,23 @@
+pkgbase = python2-odespy-git
+ pkgdesc = Easy access in Python to a large collection of ODE solvers.
+ pkgver = 0.2.0.r147.1db410c
+ pkgrel = 1
+ url = http://hplgit.github.io/odespy/doc/web/index.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = python2-setuptools
+ makedepends = gcc-fortran
+ depends = python2
+ depends = python2-numpy
+ optdepends = python2-nose: necessary for basic tests
+ optdepends = python2-sympy: used in Sympy_odefun
+ optdepends = python2-scipy: necessary for Vode, Dopri5 and Dop853 solvers
+ optdepends = python2-scitools: plot curves in demos
+ optdepends = python2-odelab
+ provides = python2-odespy
+ conflicts = python2-odespy
+ source = git+https://github.com/hplgit/odespy.git
+
+pkgname = python2-odespy-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..da9023f3452c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = python2-odespy-git
+ pkgdesc = Easy access in Python to a large collection of ODE solvers.
+ pkgver = 0.2.0.r147.1db410c
+ pkgrel = 1
+ url = http://hplgit.github.io/odespy/doc/web/index.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = python2-setuptools
+ makedepends = gcc-fortran
+ depends = python2
+ depends = python2-numpy
+ optdepends = python2-nose: necessary for basic tests
+ optdepends = python2-sympy: used in Sympy_odefun
+ optdepends = python2-scipy: necessary for Vode, Dopri5 and Dop853 solvers
+ optdepends = python2-scitools: plot curves in demos
+ optdepends = python2-odelab
+ provides = python2-odespy
+ conflicts = python2-odespy
+ source = git+https://github.com/hplgit/odespy.git
+ md5sums = SKIP
+
+pkgname = python2-odespy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f3a3085b97ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Renato Coutinho <renato.coutinho@gmail.com>
+pkgname=python2-odespy-git
+_pkgver=0.2.0
+pkgver=0.2.0.r147.1db410c
+pkgrel=1
+pkgdesc="Easy access in Python to a large collection of ODE solvers."
+arch=('i686' 'x86_64')
+url="http://hplgit.github.io/odespy/doc/web/index.html"
+license=('GPL')
+depends=('python2' 'python2-numpy')
+makedepends=('python2-setuptools' 'gcc-fortran')
+conflicts=('python2-odespy')
+provides=('python2-odespy')
+source=("git+https://github.com/hplgit/odespy.git")
+md5sums=('SKIP')
+optdepends=('python2-nose: necessary for basic tests'
+ 'python2-sympy: used in Sympy_odefun'
+ 'python2-scipy: necessary for Vode, Dopri5 and Dop853 solvers'
+ 'python2-scitools: plot curves in demos'
+ 'python2-odelab')
+
+pkgver() {
+ cd ${srcdir}/odespy
+ printf "${_pkgver}.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ${srcdir}/odespy
+ # workaround: some flag is preventing compilation to finish, need to
+ # investigate more to find out what is the problem. My flags (from
+ # makepkg.conf) are:
+ # -Wl,-O1,--sort-common,--as-needed,-z,relro
+ unset LDFLAGS
+ python2 setup.py install --prefix=/usr --root=${pkgdir}
+}