summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLubosz Sarnecki2015-06-22 22:57:28 +0200
committerLubosz Sarnecki2015-06-22 22:57:28 +0200
commitcdc9fc282151fe615e4099f88e8535042ceca787 (patch)
tree6eecd71ac93d812aac60fa160dbd494983e984ea
downloadaur-python2-openglcontext.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD32
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3893972f3272
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-openglcontext
+ pkgdesc = OpenGLcontext is a learning environment for PyOpenGL.
+ pkgver = 2.2.0a3
+ pkgrel = 1
+ url = http://pyopengl.sourceforge.net/context
+ arch = any
+ license = BSD
+ depends = python2-opengl
+ provides = python2-openglcontext
+ source = https://pypi.python.org/packages/source/O/OpenGLContext/OpenGLContext-2.2.0a3.tar.gz
+ md5sums = b5bdedbdae5215e7acff3b087c8220d3
+
+pkgname = python2-openglcontext
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..39350d79dce8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Lubosz Sarnecki <lubosz@gmail.com>
+# Contributor: Douglas Soares de Andrade <dsandrade@gmail.com>
+# Contributor: Mathieu Pasquet <mathieui> <mathieuivi@gmail.com>
+
+pkgname=python2-openglcontext
+pkgver=2.2.0a3
+pkgrel=1
+arch='any'
+pkgdesc="OpenGLcontext is a learning environment for PyOpenGL."
+depends=('python2-opengl')
+url="http://pyopengl.sourceforge.net/context"
+source=("https://pypi.python.org/packages/source/O/OpenGLContext/OpenGLContext-2.2.0a3.tar.gz")
+license='BSD' #BSD-style, though, see license.txt in the archive file
+
+provides=('python2-openglcontext')
+
+md5sums=('b5bdedbdae5215e7acff3b087c8220d3')
+
+pkgver() {
+ cd openglcontext
+ echo $(grep __version__ OpenGLContext/__init__.py | sed 's/__version__ = "//' | sed 's/"//')
+}
+
+build() {
+ cd openglcontext
+ python2 setup.py build
+}
+
+package() {
+ cd openglcontext
+ python2 setup.py install --root=$pkgdir
+}